Ergebnis 1 bis 3 von 3
  1. #1
    Neuer Benutzer
    Registriert seit
    14.05.2013
    Beiträge
    21

    error.log wird nicht angezeigt

    Hallo zusammen,

    bei mir wird den einzelnen Kunden nach Aktivierung dennoch nicht die error.log angezeigt. Es dreht sich lediglich der "Lade"-Kreis und nichts geschieht. Keine Eintragungen in der liveconfig.log.

    Die Datei ist aber vorhanden:
    Code:
    ls -al /var/www/web25/logs/
    drwxr-x--- 2 www-data web25 4.0K May 17 10:03 .
    drwxr-xr-x 8 root     root  4.0K May 17 09:56 ..
    -rw-r--r-- 1 root     root  4.0K May 17 11:19 access.log
    -rw-r--r-- 1 root     root    90 May 17 09:56 access.log.1
    -rw------- 1 root     root   503 May 17 11:19 error.log
    Nach setzen von chmod 0644 auf die error.log, funktioniert die Anzeige.

    Ist das ein Bug? Nutze Version: 1.6.2 Revision: 2334 auf Debian 7.0 (extra neuinstalliert für LiveConfig!)
    Geändert von Screeny (17.05.2013 um 11:36 Uhr)

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.587
    Apache verwendet in diesem Fall eine sicherere umask, so dass die error.log mit den Rechten des Endkunden nicht lesbar ist (der Log-Viewer öffnet Dateien aus Sicherheitsgründen grundsätzlich mit den Berechtigungen des Endkunden).
    Mit v1.6.2-r2145 wurde das apache.lua-Script so aufgebohrt, dass die error.log mit entsprechend großzügigeren Rechten angelegt wird (das übergeordnete "logs"-Verzeichnis verbietet ja einen Zugriff durch Fremde).

    Update wird in ca. 3-4 Stunden im Preview-Bereich verfügbar sein.

  3. #3
    Neuer Benutzer
    Registriert seit
    14.05.2013
    Beiträge
    21
    Wunderbärchen! Dann warte ich mal ...

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •