Ergebnis 1 bis 4 von 4
  1. #1
    Benutzer
    Registriert seit
    02.12.2014
    Beiträge
    67

    Sporadische Probleme mit milter-reject

    Hallo Community,
    ich habe heute nun zum zweiten mal in einer Woche das Problem, dass mein Postfix keine Mail mehr annimmt und folgende Meldung ausgibt:
    Code:
    postfix/cleanup[23307]: 4JSgh638dhzFjRJ: milter-reject: END-OF-MESSAGE from host.domain.tld[A.B.C.D]: 4.7.1 Service unavailable - try again later; from=<abc@sender.tld> to=<xyz@recipient.tld> proto=ESMTP helo=<host.domain.tld>
    Beim ersten mal habe ich zuerst das System neu gestartet, hat aber nichts geändert.
    Dann habe ich festgestellt, dass der clamav-milter nicht gestartet war (trotz reboot). Also gestartet -> alles wieder ok.

    Als das Problem aber heute nochmals aufgetreten ist, lief der clamav-milter. Auch ein Neustart des Servers/Dienstes hat an der Situation nichts geändert.
    Da es beim ersten mal am ClamAV lag, habe ich diesen temporär deaktiviert, damit ich meine wichtige Mail erhalten hab und diesen dann wieder aktiviert. Und schwups war das Problem weg.

    Die eigentlichen Frage ist aber: Wie kann ich das Problem fassen / debuggen?
    So ein willkürliches Problem kann man ja nicht gebrauchen.

    Systeminfos:
    Code:
    Ubuntu 18.04
    Postfix 3.3.0 (3.3.0-1ubuntu0.4)
    ClamAV (0.103.2+dfsg-0ubuntu0.18.04.2)
    SpamAssassin (3.4.2-0ubuntu0.18.04.5)
    OpenDKIM (2.11.0~alpha-11b)
    Danke für alle Ratschläge.

  2. #2
    Benutzer
    Registriert seit
    02.12.2014
    Beiträge
    67
    Ohje, sehe gerade das hier 2018 schonmal jemand das Problem geschildert hat.
    Zitat Zitat von fpschm Beitrag anzeigen
    Hallo,

    wir haben nun leider schon seit einigen Wochen das Problem, dass auf unserem Server bei eingeschaltetem ClamAV der Versand von Emails mit der Fehlermeldung "4.7.1 Service unavailable" fehlschlägt.
    Im mail.log findet sich dazu dann dieser Eintrag:
    [...]hosting postfix/cleanup[14048]: 903C2139611F: milter-reject: END-OF-MESSAGE from xxx: 4.7.1 Service unavailable - try again later[...]

    Deaktivieren wir den ClamAV, werden die Emails wieder normal versendet.
    Unsere LiveConfig Version ist: 2.5.3 Revision: 4805.
    ClamAV Version ist nun ClamAV 0.99.3/24350
    Das Problem trat in der vorhergehenden ClamAV Version bereits auf. Nachdem dann die Version 0.99.3 verfügbar wurde haben wir ein Upgrade durchgeführt, jedoch änderte sich das Problem dadurch nicht.

    Hat jemand dasselbe Problem? Oder konnte es bereits jemand lösen?
    und auch eine Antwort von @kk bekommen hat.

    Zitat Zitat von kk Beitrag anzeigen
    "Service unavailable" bedeutet in dem Zusammenhang meistens, dass der Prozess "clamd" (bzw. "clamav-daemon") nicht läuft.
    Warum der nicht mehr läuft (bzw. seinen Dienst eingestellt hat) lässt sich eventuell über die einschlägigen Log-Dateien herausfinden.

    Kürzlich gab es einen kritischen Bug im ClamAV-Daemon, über den man mit einer einzigen (präparierten) E-Mail den ClamAV abstürzen lassen konnte. Inzwischen stehen aktualisierte Debian-/Ubuntu-Pakete dafür bereit, die aber i.d.R. nur über das "updates"-Repository installiert werden (nicht über "security").

    Viele Grüße

    -Klaus Keppler
    https://www.liveconfig.com/de/forum/...e-unavailable)

    @kk Den "kritischen Bug" aus 2018 der den ClamAV zum Absturz bringt können wir wohl ausschließen, außer es gab aktuell wieder einen.
    Evtl. kann mein Post aber dann weg und ich Antworte / Frage unter dem alten Thread nochmal!?!?

  3. #3
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    232
    Zitat Zitat von sTeaLth Beitrag anzeigen
    Ohje, sehe gerade das hier 2018 schonmal jemand das Problem geschildert hat.

    @kk Den "kritischen Bug" aus 2018 der den ClamAV zum Absturz bringt können wir wohl ausschließen, außer es gab aktuell wieder einen.
    Evtl. kann mein Post aber dann weg und ich Antworte / Frage unter dem alten Thread nochmal!?!?
    Schau mal im Log nach sowas wie "ERROR: Timed out while reading clamd reply"

    Wenn die Datenbanken von ClamAV nicht sauber geladen wurden (z.B. ein File korrupt) dann knallt der milter an die Wand.
    Ist im Regelfall (sofern man auch den Milter restartet) beim nächsten Update der Daten dann auch erledigt.


    Gruß Ralf

  4. #4
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    814
    Code:
    # /etc/systemd/system/clamav-daemon.service.d/clamav_restart.conf
    [Service]
    Restart=always
    Danach ein "systemctl daemon-reload; systemctl restart clamav-daemon" und clamav wird automatisch neu gestartet.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •