Ergebnis 1 bis 7 von 7
  1. #1
    Benutzer
    Registriert seit
    03.12.2014
    Beiträge
    56

    Meldungen Dovecot / Postfix - Ubuntu 18.04.5

    Hat jemand von euch Ubuntu 18.04 am laufen und auch die folgenden Meldungen?

    Code:
    Sep  9 17:52:39 host01 postfix[12605]: Postfix is running with backwards-compatible default settings
    Sep  9 17:52:39 host01 postfix[12605]: See http://www.postfix.org/COMPATIBILITY_README.html for details
    Sep  9 17:52:39 host01 postfix[12605]: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
    Sep  9 17:52:39 host01 postfix/postfix-script[12710]: starting the Postfix mail system
    Sep  9 17:52:39 host01 postfix/master[12712]: daemon started -- version 3.3.0, configuration /etc/postfix
    
    Sep  9 17:52:42 host01 dovecot: master: Dovecot v2.2.33.2 (d6601f4ec) starting up for imap, pop3 (core dumps disabled)
    Sep  9 17:52:42 host01 dovecot: config: Warning: SSLv2 not supported by OpenSSL. Please consider removing it from ssl_protocols.
    Ich habe die Postfix und Dovecot Config auch schon neu schreiben lassen.
    Muss die Dovecot Konfig von LC nicht anders erstellt werden, damit die Meldung verschwindet?
    Die Meldung taucht bei jedem neustart von Dovecot und bei jedem delivery in eine Mailbox auf.
    Bei Postfix bin ich mir nicht sicher, ob es ggf. an meiner custom.lua liegt, aber bei Dovecot benutze ich den LC Standard.

  2. #2
    Erfahrener Benutzer
    Registriert seit
    09.07.2012
    Ort
    Spanien
    Beiträge
    293
    Auch ich wäre an einer Antwort interessiert. Ich probiere hier "postfix check" und kriege nur diese meldung:
    Code:
    postfix: Postfix is running with backwards-compatible default settings
    postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
    postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
    Geändert von ñull (15.10.2020 um 11:12 Uhr)

  3. #3
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    212
    Hi,

    gib einmal auf der Bash

    postconf compatibility_level=2

    ein und starte Postfix neu...

    Gruß Ralf

  4. #4
    Benutzer
    Registriert seit
    03.12.2014
    Beiträge
    56
    Vielen dank Ralf, aber ist die von dir benannte Lösung nicht nur temporär?
    Die Postfixkonfigurationen main.cf und master.cf werden doch von Liveconfig überschrieben (sofern nicht deaktiviert, was ich nicht will).

    Jetzt habe ich aber im Zusammenhang noch ei aktuelles Anliegen, wo mir evtl. jemand helfen kann.
    Seit gestern morgen bekomme ich noch weitere Meldungen und jetzt auch Probleme bei den Mailclients der User, die Ihre Mails nicht abrufen können.
    Code:
    Oct 26 11:15:56 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 1 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<FJdHN5Cy8efZ+nOK>
    Oct 26 11:15:56 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<9/1IN5Cy9efZ+nOK>
    Oct 26 11:33:01 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<ZAJrdJCyhc1d0XyZ>
    Oct 26 11:33:01 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<IAZsdJCyic1d0XyZ>
    Oct 26 11:33:01 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<CgxtdJCyis1d0XyZ>
    Oct 26 11:33:01 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<zCFudJCyi81d0XyZ>
    Oct 26 11:33:02 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<PjxvdJCyjM1d0XyZ>
    Oct 26 11:45:56 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<x/KfopCyEvHZ+nOK>
    Oct 26 11:45:57 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<2AmiopCyFfHZ+nOK>
    Oct 26 12:03:02 SERVER01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=X.X.X.X, lip=Y.Y.Y.Y, TLS handshaking: SSL_accept() failed: error:1408F10B:SSL routines:ssl3_get_record:wrong version number, session=<elHE35CyouBd0XyZ>
    ...
    Weil die User sich erst heute gemeldet haben, dachte ich zuerst es liegt an den Updates die ich gestern eingespielt habe.
    Aber die Updates habe ich erst um 15:09Uhr gemacht und nicht schon um 11:15Uhr.
    Meiner Meinung nach ist SSLv2/SSLv3 schon lange im dovecot deaktiviert.
    Ich habe jetzt gerade auch nochmal unter "/etc/dovecot" alles mit dem Backup von Sonntag verglichen.
    Da steht schon länger in der von liveconfig generierten "dovecot.conf" -> "ssl_protocols = !SSLv2 !SSLv3" drin.

    Gestern Nachmittag habe ich folgende Pakete aktuallisiert:
    Code:
    Start-Date: 2020-10-26  15:09:02
    Requested-By: stealth (1000)
    Install: linux-modules-extra-4.15.0-122-generic:amd64 (4.15.0-122.124, automatic), linux-headers-4.15.0-122:amd64 (4.15.0-122.124, automatic), linux-headers-4.15.0-122-generic:amd64 (4.15.0-122.124, automatic), linux-modules-4.15.0-122-generic:amd64 (4.15.0-122.124, automatic), linux-image-4.15.0-122-generic:amd64 (4.15.0-122.124, automatic)
    Upgrade: perl-base:amd64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), python2.7-dev:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), libpython3.6-minimal:amd64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), php7.2-common:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), php7.2-cgi:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), php7.2-cli:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), linux-headers-generic:amd64 (4.15.0.118.105, 4.15.0.122.109), linux-libc-dev:amd64 (4.15.0-118.119, 4.15.0-122.124), vim-common:amd64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), linux-image-generic:amd64 (4.15.0.118.105, 4.15.0.122.109), php7.2-mysql:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), python2.7-minimal:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), libpython3.6-stdlib:amd64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), php7.2-sqlite3:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), perl-modules-5.26:amd64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), sudo:amd64 (1.8.21p2-3ubuntu1.2, 1.8.21p2-3ubuntu1.3), libpython2.7:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), python2.7:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), libpython3.6:amd64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), python3.6:amd64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), libpython2.7-dev:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), php7.2-json:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), php7.2-opcache:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), php7.2-curl:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), perl-doc:amd64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), libperl5.26:amd64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), python3.6-minimal:amd64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), php7.2-imap:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), python3-distupgrade:amd64 (1:18.04.38, 1:18.04.40), ubuntu-release-upgrader-core:amd64 (1:18.04.38, 1:18.04.40), php7.2-readline:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), php7.2-gd:amd64 (7.2.24-0ubuntu0.18.04.6, 7.2.24-0ubuntu0.18.04.7), vim-runtime:amd64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), vim:amd64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), xxd:amd64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), libpython2.7-minimal:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), libfreetype6:amd64 (2.8.1-2ubuntu2, 2.8.1-2ubuntu2.1), perl:amd64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), vim-tiny:amd64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), libcryptsetup12:amd64 (2:2.0.2-1ubuntu1.1, 2:2.0.2-1ubuntu1.2), libpython2.7-stdlib:amd64 (2.7.17-1~18.04ubuntu1.1, 2.7.17-1~18.04ubuntu1.2), linux-generic:amd64 (4.15.0.118.105, 4.15.0.122.109)
    End-Date: 2020-10-26  15:10:09
    Vorher am Tag wurde Serverseitig nichts verändert.

    Kann da wohl ein Zertifikat abgelaufen sein oder hat MS gestern irgendwelche tollen Patches gemacht?
    User mit Problemen sind z.Z. Outlook User (z.B. Outlook 2013 per POP3)

    Gruß
    Simon

  5. #5
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    212
    Hi

    nein, das ist eine generelle/dauerhafte Einstellung.

    Sind das verschiedene Kunden oder ist das ein einzelner Kunde (u.U. mit mehreren Mailkonten)?

    Gruß Ralf

  6. #6
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.477
    Die Fehlermeldung ist recht allgemein; kann z.B. auch dann auftreten wenn Kunden ihren Mailclient falsch konfiguriert haben (etwa wenn ein Kunde Port 110 auswählt, statt STARTTLS da aber SSL einstellt).
    Schicken Sie uns bitte mal den Namen Ihres Mailservers an support@liveconfig.com, dann testen wir das mal soweit wie möglich von außen durch.

    Viele Grüße

    -Klaus Keppler

  7. #7
    Benutzer
    Registriert seit
    03.12.2014
    Beiträge
    56
    Hallo und vielen Dank.
    Ich konnte das Problem gerade auf den eingesetzten Virenscanner der Kundensysteme (ESET NOD32) eingrenzen. auch nach einem Update von Version 13 auf die aktuelle Version 14 bleibt das Problem bestehen. Windows Updates wurden auf den Systemen gestern nicht durchgeführt.
    Wir haben die IP des Servers erstmal aus der Protokollüberprüfung des Virenscanners entfernt und der Fehler taucht beim abrufen unserer Konten nun nicht auf. Andere Konten (iCloud) haben aber das gleich Problem. Anscheinend hat ESET sein Protokollset zurückgestuft oder kaputt gemacht.

    @KK Ich kann Ihnen gerne noch den Namen des Mailservers schicken, denke aber das Thema hat sich erledigt.
    Ich hatte auch schon einen Report über "hardenize.com" erstellt und konnte da alles wie Konfiguriert nachvollziehen.

    Dann ist das einzige Thema in diesem Thread was noch offen bleibt, warum der Dovecot beim starten die SSLv2 Warnung ausgibt obwohl die Konfiguration und der Check von extern was anderes sagt.

    Code:
    Oct 27 12:37:02 host01 dovecot: master: Dovecot v2.2.33.2 (d6601f4ec) starting up for imap, pop3 (core dumps disabled)
    Oct 27 12:37:02 host01 dovecot: config: Warning: SSLv2 not supported by OpenSSL. Please consider removing it from ssl_protocols.
    Gruß
    Simon

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •