Ergebnis 1 bis 9 von 9
  1. #1
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.449

    PHP 7.2.32, 7.3.20 und 7.4.8

    Hallo,

    unsere PHP-Pakete für Debian/Ubuntu wurden eben auf die Versionen 7.2.32, 7.3.20 und 7.4.8 aktualisiert.
    Außerdem stehen PHP 5.6.40, 7.2.32, 7.3.20 und 7.4.8 ab sofort auch für Ubuntu 20.04 LTS ("Focal Fossa") bereit.
    Last but not least gibt es nun auch fertige PHP-Pakete mit dem IonCube-Loader (aktuellste Version) für PHP 5.6-7.4.

    Die Anleitung zur Installation weiterer PHP-Versionen unter Debian/Ubuntu wurde komplett überarbeitet:
    https://www.liveconfig.com/de/kb/deb...php-versionen/

    Für "neue" Distributionen (in diesem Fall also Ubuntu 20) stellen wir keine EOL-Versionen von PHP mehr bereit - einzige Ausnahme bildet PHP 5.6, weil es doch noch eine Menge Legacy-Anwendungen gibt die das benötigen.

    Debian 8 ist seit Ende Juni 2020 auch "End of Life". Die o.g. PHP-Versionen sind die letzten PHP-Updates, die wir hierfür bereitstellen.

    Viele Grüße

    -Klaus Keppler

  2. #2
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    752
    Zitat Zitat von kk Beitrag anzeigen
    Last but not least gibt es nun auch fertige PHP-Pakete mit dem IonCube-Loader (aktuellste Version) für PHP 5.6-7.4.
    Sehr cool - Dankeschön!

  3. #3
    Erfahrener Benutzer
    Registriert seit
    02.04.2012
    Beiträge
    641
    durch die neuen PHP Updates auf Debian Stretch ist libsodium18 überflüssig geworden - Absicht?

    EDIT: im changelog steht:
    "using libsodium 1.0.18-stable on Debian 8 / Debian 9"
    ist das nun "einkompiliert" ?

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.449
    Ja, das ist nun einkompiliert - siehe https://www.liveconfig.com/de/forum/...ort-in-Stretch

  5. #5
    Erfahrener Benutzer
    Registriert seit
    06.11.2013
    Beiträge
    377
    Zitat Zitat von kk Beitrag anzeigen
    Last but not least gibt es nun auch fertige PHP-Pakete mit dem IonCube-Loader (aktuellste Version) für PHP 5.6-7.4.
    Eine vielleicht "blöde" Frage: wo findet man diese PHP-Paket und bedeutet dies, das man IonCube nicht mehr manuell (in die php.ini) einbinden muss?

  6. #6
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.449
    Zitat Zitat von weltmeister Beitrag anzeigen
    Eine vielleicht "blöde" Frage: wo findet man diese PHP-Paket und bedeutet dies, das man IonCube nicht mehr manuell (in die php.ini) einbinden muss?
    So blöd ist die Frage gar nicht, ich sehe dass das noch gar nicht dokumentiert ist. Wird gleich nachgeholt.

    Die Pakete nennen sich "php-x.y-opt-ioncube" und sind in unseren "normalen" PHP-Repositories enthalten. Mit der Installation werden diese auch automatisch in die php.ini mit aufgenommen (via /opt/php-x.y/etc/conf.d/ioncube.ini).

  7. #7
    Erfahrener Benutzer
    Registriert seit
    06.11.2013
    Beiträge
    377
    Vielen Dank!

  8. #8
    Benutzer
    Registriert seit
    17.02.2011
    Beiträge
    77
    Hm, die anderen PHP-Module / Pakete sind in der neuen Doku/Wiki ebenfalls nicht mehr aufgelistet.
    Webhosting mit Febas: Leistungsstark, einfach, günstig!

  9. #9
    Erfahrener Benutzer
    Registriert seit
    06.11.2013
    Beiträge
    377
    Installiert und gestestet - funktioniert einwandfrei!

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •