Ergebnis 1 bis 4 von 4
  1. #1
    Neuer Benutzer
    Registriert seit
    18.06.2020
    Beiträge
    2

    Multi-PHP Prob

    Hallo Zusammen,

    ich habe folgendes Problem mit einer Multi-PHP-Installation unter Debian10 Buster.
    Installiert sind php 5.6, 7.0, 7.1, bis 7.4
    liveconfig --diag liefert 2 Probleme

    1. Memcached
    NOTICE: PHP message: PHP Warning: PHP Startup: Unable to load dynamic library 'memcached.so' (tried: /usr/lib/php/20170718/memcached.so (/usr/lib/php/20170718/memcached.so: undefined symbol: php_json_decode_ex), /usr/lib/php/20170718/memcached.so.so (/usr/lib/php/20170718/memcached.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

    Versucht habe ich vollkommene Neuinstallation von memcached und memcache,
    keine Abhilfe
    Neuinstallation von allen PHP-Versionen
    keine Abhilfe

    Eigentlich sollte doch auch das Lib-Verzeichnis 20170718 veraltet sein?
    Ich sehe auch neuere lib-Verzeichnisse 20190902 oder 20180731.
    Bei der Erstinstallation hat das alles noch funktioniert, aber seit irgendeinem
    Update habe ich dies entdeckt.
    Bin mir aber leider nicht mehr sicher, welches dies war...
    Asche über mein Haupt



    2.Problem default PHP-Version

    - PHP 7.4.7 [DEFAULT] (code='php74')
    CGI/FastCGI: /usr/bin/php-cgi7.4
    FPM: /usr/sbin/php-fpm7.4
    pool config: /etc/php/7.4/fpm/pool.d
    default php.ini: '/etc/php/7.4/cgi/php.ini'
    - PHP 7.4.7 (code='php7')
    CGI/FastCGI: /usr/bin/php-cgi
    FPM: /usr/sbin/php-fpm7.0
    pool config: /etc/php/7.0/fpm/pool.d
    default php.ini: '/etc/php/7.4/cgi/php.ini'
    - default PHP CLI: /usr/bin/php

    Egal welche php7.x-Version ich über update-alternatives auswähle,
    wird der letzte Block mit gemischten/falschen PHP-Pfaden ausgegeben.
    Wo kommt das her?

    Würde mich über Hilfe freuen.
    DANKE

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.406
    Hallo,

    zu Frage 1: welcher PHP-Interpreter genau liefert diese Fehlermeldung?
    führen Sie nacheinander mal folgende Befehle aus:
    Code:
    php -v
    /opt/php-5.6/bin/php -v
    /opt/php-7.0/bin/php -v
    /opt/php-7.1/bin/php -v
    /opt/php-7.2/bin/php -v
    /opt/php-7.3/bin/php -v
    /opt/php-7.4/bin/php -v
    zu Frage 2: update-alternatives hat hiermit nichts zu tun (das betrifft nur Debian selbst, nicht aber LiveConfig).
    Haben Sie manuell irgendetwas in einer .lua-Datei (/etc/liveconfig/lua.d/*.lua oder in /usr/lib/liveconfig/lua/custom.lua eingestellt?
    Schicken Sie uns bitte ggf. mal die gesamte Ausgabe der PHP-Erkennung von "liveconfig --diag" an support@liveconfig.com

    Viele Grüße

    -Klaus Keppler

  3. #3
    Neuer Benutzer
    Registriert seit
    18.06.2020
    Beiträge
    2
    zu Thema 1

    root@myhost:/usr/lib/php# php -v
    PHP 7.4.7 (cli) (built: Jun 12 2020 07:47:45) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.7, Copyright (c), by Zend Technologies
    with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans
    root@myhost:/usr/lib/php# /usr/bin/php5.6 -v
    PHP 5.6.40-29+0~20200514.35+debian10~1.gbpcc49a4 (cli)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
    with Xdebug v2.5.5, Copyright (c) 2002-2017, by Derick Rethans
    root@myhost:/usr/lib/php# /usr/bin/php7.0 -v
    PHP 7.0.33-29+0~20200514.36+debian10~1.gbp126f6f (cli) (built: May 14 2020 09:10:44) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.33-29+0~20200514.36+debian10~1.gbp126f6f, Copyright (c) 1999-2017, by Zend Technologies
    with Xdebug v2.8.1, Copyright (c) 2002-2019, by Derick Rethans
    root@myhost:/usr/lib/php# /usr/bin/php7.1 -v
    PHP 7.1.33-16+0~20200514.38+debian10~1.gbp1e5820 (cli) (built: May 14 2020 13:41:21) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.1.33-16+0~20200514.38+debian10~1.gbp1e5820, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans
    root@myhost:/usr/lib/php# /usr/bin/php7.2 -v
    PHP 7.2.31-1+0~20200514.41+debian10~1.gbpe2a56b (cli) (built: May 14 2020 08:32:35) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.31-1+0~20200514.41+debian10~1.gbpe2a56b, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans
    root@myhost:/usr/lib/php# /usr/bin/php7.3 -v
    PHP 7.3.19-1+0~20200612.60+debian10~1.gbp6c8fe1 (cli) (built: Jun 12 2020 07:48:33) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.19, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.19-1+0~20200612.60+debian10~1.gbp6c8fe1, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans
    root@myhost:/usr/lib/php# /usr/bin/php7.4 -v
    PHP 7.4.7 (cli) (built: Jun 12 2020 07:47:45) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.7, Copyright (c), by Zend Technologies
    with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans

    Danke für die schnelle Reaktion
    und Viele Grüße
    - Klaus B

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.406
    für eventuelle Mitleser: vermutlich war das o.g. Verhalten eine Nebenwirkung aus der Umstellung der PHP-Version via update-alternatives.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •