Startseite » Forum » LiveConfig-Foren (deutsch) » Fehler und Problembehebung » Hostdatei wird nicht angelegt
Ergebnis 1 bis 8 von 8
  1. #1
    Neuer Benutzer
    Registriert seit
    21.09.2019
    Beiträge
    10

    Hostdatei wird nicht angelegt

    Hallo,

    Ubuntu 18.04. V 2.9.3-release + apache2

    Seit Stunden bin ich nun dabei und richte immer wieder den Host neu ein, richte das Zertifikat ein, webserver config ok wie immer, exklusive IP, Domain über A-Record alle Haken gesetzt und alles korrekt eingerichtet.

    Port 80 sagt das die Domain nicht verfügbar ist und SSL meldet SSL Protocol error. Nach nun intensiver Fehlersuche und vielen grauen Haaren stelle ich fest, dass livconfig aktuell scheinbar den Host nicht richtig einrichtet. Liveconfig legt zumindest nicht wie üblich eine webx.conf an. Nur die default000.conf ist in /apache2/sites-enabled angelegt.

    PHP-Code:
    [2020/03/17 13:54:11.966278] [32398|32398SSL read error (IP=xx.xx.xx.xx): error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown
    [2020/03/17 13:54:34.425477] [32398|32406] (last message repeated 3 times)
    [
    2020/03/17 13:54:34.429250] [32399|32401] [LUALC.mutexforcing unlock of mutex 'web.configure'
    [2020/03/17 13:54:34.430889] [32399|32401LC.web.configureVHost(web2)) failed: /usr/lib/liveconfig/lua/web.lua:1113table index is nil
    stack traceback
    :
            /
    usr/lib/liveconfig/lua/web.lua:1113in function </usr/lib/liveconfig/lua/web.lua:1080>
    [
    2020/03/17 13:54:34.854379] [32398|32398SSL read error (IP=xx.xx.xx.xx): error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown
    [2020/03/17 13:54:44.646268] [32399|32400] [LUALC.exec(/etc/init.d/apache2 restart): program outputRestarting apache2 (via systemctl): apache2.service
    Keine Ahnung wie ich gerade weiter machen soll.

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.390
    Scheinbar passt was mit den verfügbaren und den gewählten PHP-Versionen nicht zusammen.
    Posten Sie bitte mal die Ausgabe von "liveconfig --diag" (der Bereich rund um die PHP-Versionen genügt)

    Viele Grüße

    -Klaus Keppler

  3. #3
    Neuer Benutzer
    Registriert seit
    21.09.2019
    Beiträge
    10
    Zitat Zitat von kk Beitrag anzeigen
    Scheinbar passt was mit den verfügbaren und den gewählten PHP-Versionen nicht zusammen.
    Posten Sie bitte mal die Ausgabe von "liveconfig --diag" (der Bereich rund um die PHP-Versionen genügt)

    Viele Grüße

    -Klaus Keppler
    Also eingestellt ist PHP FPM mit Apache2 Proxy was NIL ist weiß ich nicht.


    PHP-Code:
    IPMI:
      
    ERRORIPMI not supported in this build
    QUOTA 
    for group 'root' at path /var/wwwERROR No such process
    Running Lua diagnostics
    ...
    [
    INFODetected 'Ubuntu 18.04.4 LTS'
    [ERRaddPHPmissing parameter 'cgi' (FastCGI binary required!)
    [
    ERRselected PHP default version 'nil' not foundUsing 'nil'...
           
    Distribution name'Ubuntu'
       
    Distribution codename'bionic'
         
    Distribution family'Debian'
        
    Distribution version'18.04'
    Distribution description'Ubuntu 18.04.4 LTS' 
    und ich hab tatsächlich mit web2 keinen Zugriff auf /var/www die Rechte passen aber wie ich das sehen konnte...

    aktive Module mit Haken in Liveconfig:

    proxy_fcgi (PHP-FPM)
    http2
    proxy
    rewrite
    ssl

    soll ich das fastcgi noch aktivieren?

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.390
    Bei der Ausgabe vom "liveconfig --diag" fehlt leider die Info zum Webserver/PHP. Das sieht normalerweise ungefähr so aus:
    Code:
    [INFO]Detected 'Ubuntu 18.04.3 LTS'
           Distribution name: 'Ubuntu'
       Distribution codename: 'bionic'
         Distribution family: 'Debian'
        Distribution version: '18.04'
    Distribution description: 'Ubuntu 18.04.3 LTS'
    Checking for web server software:
     - Found 'apache' web server
       Version: '2.4.29'
       Package version: '2.4.29-1ubuntu4.11'
       Modules: core so watchdog http log_config logio version unixd access_compat actions alias auth_basic authn_core authn_file authz_core authz_host authz_user autoindex deflate dir env fcgid filter http2 include mime mpm_event negotiation proxy proxy_fcgi reqtimeout rewrite setenvif socache_shmcb ssl suexec
     - PHP 7.2.24 [DEFAULT] (code='php7')
       CGI/FastCGI: /usr/bin/php-cgi
       FPM: /usr/sbin/php-fpm7.2
            pool config: /etc/php/7.2/fpm/pool.d
       default php.ini: '/etc/php/7.2/cgi/php.ini'
     - default PHP CLI: /usr/bin/php
    Checking for ftp server software:
    [...]

  5. #5
    Neuer Benutzer
    Registriert seit
    21.09.2019
    Beiträge
    10
    Da wird wohl der Fehler sein, gibt es so nämlich nicht:
    Code:
    Running Lua diagnostics...
    [INFO] Detected 'Ubuntu 18.04.4 LTS'
    [ERR] addPHP: missing parameter 'cgi' (FastCGI binary required!)
    [ERR] selected PHP default version 'nil' not found! Using 'nil'...
           Distribution name: 'Ubuntu'
       Distribution codename: 'bionic'
         Distribution family: 'Debian'
        Distribution version: '18.04'
    Distribution description: 'Ubuntu 18.04.4 LTS'
    Checking for web server software:
     - Found 'apache' web server
       Version: '2.4.29'
       Package version: '2.4.29-1ubuntu4.12'
       Modules: core so watchdog http log_config logio version unixd access_compat alias auth_basic authn_core authn_file authz_core authz_host authz_user autoindex deflate dir env filter http2 mime mpm_event negotiation proxy proxy_fcgi reqtimeout rewrite setenvif socache_shmcb ssl status
     - default PHP CLI: /usr/bin/php
    Checking for ftp server software:
    Checking for SMTP server software:
    /usr/sbin/postconf: fatal: open /etc/postfix/main.cf: No such file or directory
     - SpamAssassin: NOT FOUND
     - OpenDKIM: NOT FOUND
    Checking for POP/IMAP server software:
    Checking for database server software:
    Checking for DNS server software:
    Done.
    Die Pakete php und php-fpm sind allerdings installiert
    Geändert von Nobbi (17.03.2020 um 19:49 Uhr)

  6. #6
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    740
    Zitat Zitat von Nobbi Beitrag anzeigen
    Die Pakete php und php-fpm sind allerdings installiert
    php-cgi fehlt dann.

  7. #7
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.390
    Ja, ich würde mal php-cgi installieren und versuchen ob "liveconfig --diag" dann die PHP-Erkennung korrekt ausführt.
    Wobei es eigentlich auch in dieser Kombination funktionieren sollte (also nur mit php-fpm) - das testen wir morgen bei uns mal durch.

  8. #8
    Neuer Benutzer
    Registriert seit
    21.09.2019
    Beiträge
    10
    Hat funktioniert, php-cgi aber die Domains sind noch immer nicht erreichbar, web nochmal neu anlegen?

    Code:
    QUOTA for group 'root' at path /var/www: ERROR - No such process
    Running Lua diagnostics...
    [INFO] Detected 'Ubuntu 18.04.4 LTS'
           Distribution name: 'Ubuntu'
       Distribution codename: 'bionic'
         Distribution family: 'Debian'
        Distribution version: '18.04'
    Distribution description: 'Ubuntu 18.04.4 LTS'
    Checking for web server software:
     - Found 'apache' web server
       Version: '2.4.29'
       Package version: '2.4.29-1ubuntu4.12'
       Modules: core so watchdog http log_config logio version unixd access_compat alias auth_basic authn_core authn_file authz_core authz_host authz_user autoindex deflate dir env filter http2 mime mpm_event negotiation proxy proxy_fcgi reqtimeout rewrite setenvif socache_shmcb ssl status
     - PHP 7.2.24 [DEFAULT] (code='php7')
       CGI/FastCGI: /usr/bin/php-cgi
       FPM: /usr/sbin/php-fpm7.2
            pool config: /etc/php/7.2/fpm/pool.d
       default php.ini: '/etc/php/7.2/cgi/php.ini'
     - default PHP CLI: /usr/bin/php
    Checking for ftp server software:
    Checking for SMTP server software:

    ---- edit, jetzt gehts alles nochmal neu gestartet passt
    Geändert von Nobbi (17.03.2020 um 21:24 Uhr)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •