Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20
  1. #1
    Neuer Benutzer
    Registriert seit
    15.03.2016
    Beiträge
    8

    PHP Upload Probleme seit Upgrade auf Debian Buster/Liveconfig 2.9.1

    Hallo,

    seit dem Upgrade auf Debian Buster inkl. Liveconfig 2.9.1 schlägt jeder Upload mit PHP 5.6.40 fehl, da der clamscan mit Exit 2 beendet wird, wenn dieser vom PHP aufgerufen wird.
    Als quick&dirty fix, haben wir mal ein exit 0 ins /usr/lib/liveconfig/uploadscan.sh hinein genommen, damit die uploads wieder funktionieren...


    strace php

  2. #2
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    232
    Hmm. wir haben bei uns extra den Upload mit PHP 5.6.x ausgeschaltet damit Kunden endlich auf PHP 7.x gehen ;-)

    Die PHP 5.6.x ist nicht umsonst schon eine ganze Zeit unsupported/EOL ...

  3. #3
    Erfahrener Benutzer
    Registriert seit
    15.02.2016
    Beiträge
    320
    PHP 5.6 entfernen.
    # Das Gras wächst nicht schneller wenn man daran zieht # Bitte keine inflationären Vollzitate #

  4. #4
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    232
    Ja. Sollte man machen.

  5. #5
    Neuer Benutzer
    Registriert seit
    20.02.2020
    Beiträge
    3
    Zitat Zitat von lebenszeit Beitrag anzeigen
    PHP 5.6 entfernen.
    Super Idee, wenn man mehrere Kunden hat, die PHP 5.6 nutzen. Mir gefällt der Ansatz sehr gut, auch finde ich toll, wie die Antwort auf das eigentliche Anliegen, bzw. die Fehlerbeschreibung des Threaderstellers eingeht.

    Top IT-Consulting.

  6. #6
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    232
    Entschuldige. Genau aus diesem Grund fahren wir bei uns Funktionalitäten in Uralt-Versionen (mit Ankündigung) zurück. Nur so kann man Kunden nachhaltig zwingen auf neuere Versionen umzustellen.

    Es macht übrigens durchaus sehr viel Sinn, Kunden zu "überreden". Ungefixte Sicherheitslücken stellen ein Risiko dar und wenn man nichts tut, hat man in ein paar Jahren immer noch einen Server mit der Uraltversion (wir haben am Montag erst einen Fremdserver mit PHP 4.3 und Confixx 1.6 auf Liveconfig migriert).

    https://www.php.net/supported-versions.php

  7. #7
    Neuer Benutzer
    Registriert seit
    20.02.2020
    Beiträge
    3
    Danke, das ist alles schön und gut, der Zusammenhang mit dem Originalpost ist dennoch schwer herzustellen, denn es wird auf einen Bug in Liveconfig hingewiesen.

    Ein ähnlich sinnvoller Ansatz wäre zu sagen "Wenn ich Liveconfig nicht verwende, dann habe ich das Problem ebenfalls nicht".

  8. #8
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    232
    Wo ist der Bug in Liveconfig? Das erschließt sich mir nicht.

  9. #9
    Neuer Benutzer
    Registriert seit
    20.02.2020
    Beiträge
    3
    Ist in dem vielen Text rund um den Triggerstring "PHP 5.6.40" im OP versteckt.

  10. #10
    Erfahrener Benutzer
    Registriert seit
    21.02.2011
    Beiträge
    340
    Zitat Zitat von suppenuser Beitrag anzeigen
    Wo ist der Bug in Liveconfig? Das erschließt sich mir nicht.
    Das ist eine von LC zur Verfügung gestellte Version. Wobei ich diesen Bug auch schon hatte, der Leidensdruck war aber nicht hoch genug um da weiter nachzuforschen.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •