Startseite » Forum » LiveConfig-Foren (deutsch) » Fehler und Problembehebung » [ERR] addPHP: missing parameter 'cgi' (FastCGI binary required!)
Ergebnis 1 bis 2 von 2
  1. #1
    Erfahrener Benutzer
    Registriert seit
    06.06.2014
    Ort
    München
    Beiträge
    127

    [ERR] addPHP: missing parameter 'cgi' (FastCGI binary required!)

    Servus, kennt jemand diesen Fehler und weiß Abhilfe?

    Code:
    [ERR] addPHP: missing parameter 'cgi' (FastCGI binary required!)
    [ERR] selected PHP default version 'nil' not found! Using 'nil'...
    Fällt mir auf, seit Wechsel von Debian 8 auf 9.
    Der Fehler tritt auch dann auf, wenn nur PHP Opt Pakete installiert sind, die aus dem LC-Repo kommen.

    Code:
    20007# /usr/sbin/liveconfig --diag
    Running OS diagnostics... (LiveConfig 2.9.1-release)
    ...
    Running Lua diagnostics...
    [INFO] Loading custom Lua settings from '/usr/lib/liveconfig/lua/custom.lua'
    [INFO] Detected 'Debian GNU/Linux 9.11 (stretch)'
    [ERR] addPHP: missing parameter 'cgi' (FastCGI binary required!)
    [ERR] selected PHP default version 'nil' not found! Using 'nil'...
           Distribution name: 'Debian'
       Distribution codename: 'stretch'
         Distribution family: 'Debian'
        Distribution version: '9.11'
    Distribution description: 'Debian GNU/Linux 9.11 (stretch)'
    Checking for web server software:
     - Found 'apache' web server
       Version: '2.4.25'
       Package version: '2.4.25-3+deb9u9'
       Modules: core so watchdog http log_config logio version unixd access_compat actions alias auth_basic authn_core authn_file authz_core authz_groupfile authz_host authz_user autoindex cgi cgid deflate dir env expires fcgid filter geoip headers http2 include info mime mpm_event negotiation proxy proxy_fcgi proxy_http reqtimeout rewrite setenvif socache_shmcb ssl status suexec
     - PHP 5.6.40 (code='php56')
       CGI/FastCGI: /opt/php-5.6/bin/php-cgi
       FPM: /opt/php-5.6/sbin/php-fpm
            pool config: /etc/php-fpm/php56-fpm.d
       default php.ini: '/opt/php-5.6/etc/php.ini'
     - PHP 7.0.33 (code='php70')
       CGI/FastCGI: /opt/php-7.0/bin/php-cgi
       FPM: /opt/php-7.0/sbin/php-fpm
            pool config: /etc/php-fpm/php70-fpm.d
       default php.ini: '/opt/php-7.0/etc/php.ini'
     - PHP 7.1.33 (code='php71')
       CGI/FastCGI: /opt/php-7.1/bin/php-cgi
       FPM: /opt/php-7.1/sbin/php-fpm
            pool config: /etc/php-fpm/php71-fpm.d
       default php.ini: '/opt/php-7.1/etc/php.ini'
     - PHP 7.2.26 (code='php72', eol='2020-11-30')
       CGI/FastCGI: /opt/php-7.2/bin/php-cgi
       FPM: /opt/php-7.2/sbin/php-fpm
            pool config: /etc/php-fpm/php72-fpm.d
       default php.ini: '/opt/php-7.2/etc/php.ini'
     - PHP 7.3.13 (code='php73', eol='2021-12-06')
       CGI/FastCGI: /opt/php-7.3/bin/php-cgi
       FPM: /opt/php-7.3/sbin/php-fpm
            pool config: /etc/php-fpm/php73-fpm.d
       default php.ini: '/opt/php-7.3/etc/php.ini'
     - PHP 7.4.1 (code='php74')
       CGI/FastCGI: /opt/php-7.4/bin/php-cgi
       FPM: /opt/php-7.4/sbin/php-fpm
            pool config: /etc/php-fpm/php74-fpm.d
       default php.ini: '/opt/php-7.4/etc/php.ini'
     - default PHP CLI: /usr/bin/php
    ...
    Inhalt der Datei /usr/lib/liveconfig/lua/custom.lua:

    Code:
    postfix.NOUPDATE = true
    Danke und Gruß, Andre

  2. #2
    Erfahrener Benutzer
    Registriert seit
    06.06.2014
    Ort
    München
    Beiträge
    127
    Ok, sehr spannend.

    ich habe das das PHP von Debian wieder installiert und dann noch das Paket php-cgi installiert, nun ist der Fehler weg. Zuvor waren die PHP-Pakete von Debian deinstalliert, aber nicht purged

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •