Startseite » Forum » LiveConfig-Foren (deutsch) » Feedback und Vorschläge » PHP >= 7.2 Argon2 Support
Ergebnis 1 bis 3 von 3
  1. #1
    Benutzer
    Registriert seit
    25.07.2013
    Ort
    Paderborn
    Beiträge
    47

    Idee PHP >= 7.2 Argon2 Support

    Hallo,

    wäre es möglich ab demnächst die PHP 7.2 und 7.3 Pakete mit Argon2 zu bauen?:

    TYPO3 setzt darauf standardmäßig mittlerweile:
    https://wiki.typo3.org/Exception/CMS/1533822084

    Siehe auch: https://wiki.php.net/rfc/argon2_password_hash

    Configure benötigt: --with-password-argon2

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.187
    Für PHP 7.2 haben wir das inzwischen in unser Buildsystem aufgenommen, PHP 7.3 folgt nächste Woche.
    Beim nächsten PHP-Update wird Argon2 dann unterstützt (voraussichtlich in ca. 2-3 Wochen).

    Auch unter Debian 8 und Ubuntu 16 (die keine libargon2 mitbringen) wird PHP Argon2 unterstützen (da haben wir die notwendige Bibliothek statisch in die Argon2-Extension gelinkt).

  3. #3
    Benutzer
    Registriert seit
    25.07.2013
    Ort
    Paderborn
    Beiträge
    47
    Super vielen Dank!

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •