Ergebnis 1 bis 6 von 6

Thema: soap Fehler

  1. #1
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    236

    soap Fehler

    Hallo,
    ich nutze zum Einrichten der Bestellungen das Liveconfig Plugin von Joomisp.
    Bisher hat die Einrichtung immer funktioniert.

    Jetzt kommt auf allen Liveconfig-Servern folgende Fehlermeldung.

    Es ist ein Fehler aufgetreten
    0 SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://meinedomain:8443/liveconfig/soap?wsdl&l=admin&p=meinpasswort' : failed to load external entity "https://meinedomain:8443/liveconfig/soap?wsdl&l=admin&p=meinpasswort"

    Wenn ich https://meinedomain:8443/liveconfig/soap aufrufe kommt folgendes.

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
    <SOAP-ENV:Body>
    <SOAP-ENV:Fault>
    <faultcode>SOAP-ENV:Server</faultcode>
    <faultstring>No POST request</faultstring>
    </SOAP-ENV:Fault>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>
    Geändert von dicker (04.06.2019 um 07:59 Uhr)

  2. #2
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    645
    Zitat Zitat von dicker Beitrag anzeigen
    Jetzt kommt auf allen Liveconfig-Servern folgende Fehlermeldung.

    Es ist ein Fehler aufgetreten
    0 SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://meinedomain:8443/liveconfig/soap?wsdl&l=admin&p=meinpasswort' : failed to load external entity "https://meinedomain:8443/liveconfig/soap?wsdl&l=admin&p=meinpasswort"
    Wurde PHP-Fehler-Log geprüft?

    Was passiert beim Aufruf der URL via CURL als POST? (curl -XPOST https://....?wsdl)

  3. #3
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    236
    In den Logs kann ich nichts finden.
    Wie gesagt, es betrifft 3 Server gleichzeitig. Das ist schon eigenartig.

    Wenn ich curl -XPOST https://meinedomain:8443/liveconfig/soap?wsdl

    dann kommt -bash: curl: command not found

    curl ist installiert.
    Es wurden ja auch keine Änderungen am Server vorgenommen.
    Ist der Pfad richtig?

  4. #4
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    645
    Zitat Zitat von dicker Beitrag anzeigen
    In den Logs kann ich nichts finden.
    Wie gesagt, es betrifft 3 Server gleichzeitig. Das ist schon eigenartig.
    Die alle aus der gleichen JoomISP-Installation gepflegt werden?

    Wenn ich curl -XPOST https://meinedomain:8443/liveconfig/soap?wsdl

    dann kommt -bash: curl: command not found

    curl ist installiert.
    PHP-CURL möglicherweise ja, "curl" in der Shell offenbar nicht.

  5. #5
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    236
    Ich habe curl nochmal installiert und nun kam beim Aufruf von
    curl -XPOST https://meinedomain:8443/liveconfig/soap?wsdl

    curl: (6) Could not resolve host: meinedomain.de

    Offenbar kann curl den Host nicht auflösen. Aber warum ist das plötzlich so und das auch noch auf 3 Server.
    Geändert von dicker (04.06.2019 um 17:17 Uhr)

  6. #6
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    236
    Bei dem eingefügten Link hatte die Domainendung gefehlt.

    Jetzt bekomme ich folgende Ausgabe.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
    <head>
    <meta http-equiv="Content-Type" content="application/xhtml+xml; charset=utf-8" />
    <meta http-equiv="Imagetoolbar" content="no" />
    <title>Error 411: Length Required</title>
    <meta name="Robots" content="noindex, nofollow, noarchive" />
    <meta name="Googlebot" content="noarchive" />
    <meta name="MSSmartTagsPreventParsing" content="true" />
    <meta name="Content-Language" content="en" />
    <link rel="shortcut icon" href="/res/m/liveconfig/favicon.ico" />
    <style type="text/css">
    body { background-color:#FFFFFF; font-family:Arial, Helvetica, sans-serif; font-size:13px; line-height:15px; }
    h1 { font-family: Times, Times New Roman, Serif; font-size: 28px; line-height:32px; font-weight:normal; margin-top:30px; margin-bottom:30px; background-color:#EEEEEE; }
    address { border-top:1px solid #CCCCCC; font-size:11px; color:#999999; font-style:normal; margin-top:40px; }
    address a { color:#999999; }
    address a:hover { color:#3333FF; }
    </style>
    </head>
    <body>
    <h1>Error 411: Length Required</h1>
    <p>An error occured while processing your request: <code>Missing or invalid 'content-length:' header</code></p>
    <address>Created by <a href="http://www.liveconfig.com" title="LiveConfig® Website">LiveConfig<sup>®</sup></a></address>
    </body>
    </html>

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •