Startseite » Forum » LiveConfig-Foren (deutsch) » Fehler und Problembehebung » Liveconfig mit Fastcgi ohne mod_php und owncloud
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12
  1. #1
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    35

    Frage Liveconfig mit Fastcgi ohne mod_php und owncloud

    Hallo zusammen,
    nach dem Update jessie zu stretch und aktualisierung auf PHP 7.0 haben wir statt mod_php (libapache2-mod-php7.0) fastcgi (libapache2-mod-fcgid) installiert, seit dem läuft owncloud nicht mehr. Nach einer Recherche haben wir die Specs von owncloud gefunden, wo drin steht, benötigt mod_php.
    Muss man das wirklich wieder installieren, damit owncloud läuft? Es wird bei shared-hosting doch davon abgeraten^^
    Evtl. hat jmd. eine Lösung ohne mod_php für uns.
    Danke vorab.
    MfG

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.123
    Nein, owncloud braucht definitiv kein mod_php (davon ist allgemein dringend abzuraten).
    Wenn Sie von mod_php auf FastCGI umgestellt haben, dann vermute ich, dass die ganzen Dateiberechtigungen nicht (mehr) stimmen.

    Alle Dateien in /var/www/<Vertrag>/htdocs/ müssen dem Vertragsnamen/-Gruppe gehören, also bei "web1" z.B. dem Benutzer "web1" und der Gruppe "web1".
    (mit mod_php sah das anders aus, da mussten die Dateien alle dem Webserver-User, also "www-data" gehören).

    Um die Rechte anzupassen, führen Sie also z.B. so was aus:
    chown -R webX:webX /var/www/webX/htdocs/*

    (bzw. falls Sie ownCloud über den AppInstaller instaliert haben: chown -R webX:webX /var/www/webX/apps/*)

    ("webX" durch den jeweiligen Vertragsnamen ersetzen)

    Viele Grüße

    -Klaus Keppler

  3. #3
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.123
    Noch etwas: unter "Hosting" -> "Webspace" können Sie die php.ini-Einstellungen bearbeiten. Aktivieren Sie dort die Option "log_errors" (also auf "On" stellen). Damit sollte in /var/www/<Vertrag>/logs/priv/ auch ein php_errors.log o.ä. geschrieben werden. Sofern beim Aufruf von ownCloud dann ein Fehler auftritt, sollte man dort weitere Infos finden.

  4. #4
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    35
    Habe jetzt mal noch zusätzlich php7.0-fpm installiert, danach scheint es zu laufen, normal das man das zusätzlich noch braucht? Nur libapache2-mod-fcgid ging nicht^^ Das mit den Rechten hatte ich vorher schon angepasst gehabt. Interessant im Admin Bereich ist, dass fcgid nen grünen Haken hat aber proxy_fcgi (PHP-FPM) nicht, obwohl ich php7.0-fpm installiert habe und es danach nun läuft?!
    Geändert von informant (03.04.2019 um 16:37 Uhr)

  5. #5
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.123
    Zitat Zitat von informant Beitrag anzeigen
    Habe jetzt mal noch zusätzlich php7.0-fpm installiert, danach scheint es zu laufen, normal das man das zusätzlich noch braucht? Nur libapache2-mod-fcgid ging nicht^^
    Ich kann mir eher vorstellen, dass php7.0-cgi gefehlt hatte und über Abhängigkeiten via php7.0-fpm mit installiert wurde.

    Interessant im Admin Bereich ist, dass fcgid nen grünen Haken hat aber proxy_fcgi (PHP-FPM) nicht, obwohl ich php7.0-fpm installiert habe und es danach nun läuft?!
    mod_proxy_fcgi ist ein separates Apache-Modul, das bei Debian standardmäßig nicht aktiviert ist. Man benötigt das, wenn man PHP-FPM nutzen möchte.

  6. #6
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    35
    Danke für die Rückmeldung, das paket war auch installiert. Folgende hatte ich installiert: php7.0-cli php7.0-common php7.0-cgi php7.0-curl apache2-suexec-custom php7.0-mysql php7.0-intl php7.0-sqlite3 php7.0-mbstring php7.0-imap php7.0-gd php7.0-zip php7.0-soap php7.0-apcu php7.0-xml php7.0-mcrypt libapache2-mod-fcgid und als das nicht ging noch php7.0-fpm, kann ich fpm und cgi parallel laufen lassen oder gibt es noch eine Idee, was fehlen könnte, ohne das fpm installiert sein muss?

  7. #7
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.123
    FPM (bzw. php7.0-fpm) muss definitiv nicht installiert sein, um PHP via FastCGI (mod_fcgid) nutzen zu können. Es gab da sicher irgendeinen anderen Grund.
    Sie können das Paket "php7.0-fpm" getrost deinstallieren. Starten Sie LiveConfig anschließend neu (um die Modul-Liste zu aktualisieren).

    Viele Grüße

    -Klaus Keppler

  8. #8
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    35
    Dann läuft ownCloud nicht mehr mit besagten Fehler,,,

  9. #9
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.123
    So lange PHP in dem Webspace nicht als FPM konfiguriert ist, wird auch kein FPM benötigt - definitiv.

    Im Zweifelsfall prüfen Sie bitte mal die vHost-Konfiguration in /etc/apache2/sites-enabled/<Vertrag>.conf und suchen dort nach der Zeile "# PHP configuration for this subscription:".

    Wenn es beim Aufruf von ownCloud nur eine weiße Seite gibt, tritt wahrscheinlich ein Fehler während der PHP-Ausführung auf. Mit dem Apache-Errorlog und dem PHP-Errorlog lässt sich der auslesen.
    (entweder in /var/log/apache2/error.log schauen, oder unter "Hosting" -> "Webspace" das Fehlerprotokoll für 24Std aktivieren; zudem in den php.ini-Einstellungen des Vertrags die php.ini-Option "log_errors" auf "on" setzen).

    Im Zweifelsfall schicken Sie uns bitte mal die vHost-Konfiguration (/etc/apache2/sites-enabled/<Vertrag>.conf) und die Ausgabe von "liveconfig --diag" an support@liveconfig.com

    Viele Grüße

    -Klaus Keppler

  10. #10
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    35
    Das mit dem vhost war eine gute Idee, danke, es waren noch php5 pakete installiert die er nicht alle deinstalliert hatte. Nach dem remove mit purge und erneutem reload von liveconfig sowie vorherigem erneuern der IP gruppe im adminbereich steht in der vhos conf noch immer:
    FcgidWrapper /var/www/web207/conf/php7/php-fcgi-starter .php
    FcgidWrapper /var/www/web207/conf/php7/php-fcgi-starter .php5
    php5 mit drin, Normal?

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •