Ergebnis 1 bis 3 von 3
  1. #1
    Benutzer
    Registriert seit
    03.12.2014
    Beiträge
    58

    date.timezone nicht gesetzt in .../php56/php.ini

    Ich habe die Optionalen Liveconfig php Packete (56/70/72) für Ubuntu 16.04 installiert.
    Ich bekomme beim nutzen der "date" Funktion mit php56 die folgende Meldung:
    Code:
    date(): It is not safe to rely on the system's timezone settings…
    Wenn ich nun nach der Option "date.timezone" in der php.ini suche, finde ich die Option nur in den php70 / php76 conf Ordnern.
    Code:
    grep date.timezone /var/www/webXY/conf/php*/php.ini 
    /var/www/webXY/conf/php70/php.ini:date.timezone = Europe/Berlin
    /var/www/webXY/conf/php72/php.ini:date.timezone = Europe/Berlin
    Ich habe mit geholfen, in dem ich unter "/opt/php-5.6/etc/conf.d/" eine "custom.ini" angelegt habe.
    Code:
    cat /opt/php-5.6/etc/conf.d/custom.ini 
    [Date]
    date.timezone = Europe/Berlin
    Ist die Option "date.timezone" in php56 noch kein Standard oder warum wird diese nicht gesetzt

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.519
    Zitat Zitat von sTeaLth Beitrag anzeigen
    Ist die Option "date.timezone" in php56 noch kein Standard oder warum wird diese nicht gesetzt
    Soweit ich weiß ist diese Option standardmäßig in der php.ini auskommentiert. (PHP kann ja nicht wissen, in welchem Land es gerade eingesetzt wird)

    Die sauberste Lösung ist:
    • im LiveConfig als "admin" anmelden
    • zur php.ini-Verwaltung gehen
    • dort einen neuen Eintrag vom Typ "Zeichenkette" anlegen. Name="date.timezone", Wert="Europe/Berlin". Änderungen durch den Kunden ggf. erlauben.

    Damit landet diese Einstellung dann in allen mit LiveConfig genutzten PHP-Versionen.

    Viele Grüße

    -Klaus Keppler

  3. #3
    Benutzer
    Registriert seit
    03.12.2014
    Beiträge
    58
    Hab ich so umgesetzt.
    Vielen Dank

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •