Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13
  1. #1
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    257

    Default SSL Certificate abgelaufen

    Hallo,
    mein Default SSL Certificate ist abgelaufen. Wie kann man das aktivieren?

  2. #2
    Erfahrener Benutzer
    Registriert seit
    02.09.2014
    Beiträge
    100
    my default expires too

  3. #3
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    257
    Kannst du das bitte etwas genauer erklären was ich wo zu machen habe?

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.651
    Welches Zertifikat genau? Das von der LiveConfig-Weboberfläche?
    Dieses SSL-Zertifikat ist unter /etc/liveconfig/sslcert.pem gespeichert.

    Wenn Sie kein "offizielles" SSL-Zertifikat nutzen sondern ein neues selbst-signiertes Zertifikat anlegen möchten, verwenden Sie folgende Befehle:
    Code:
    openssl genrsa 4096 >sslcert.pem
    openssl req -x509 -key sslcert.pem -days 730 >>sslcert.pem
    Anschließend LiveConfig neu starten.

  5. #5
    Benutzer
    Registriert seit
    11.11.2015
    Beiträge
    41
    Ich glaube das geht um das Default Server-Zertifikat für SSL für den Webserver - steht in der Liste der SSL-Zertifikate mit der Bemerkung "Default SSL-zertifikat für SNI"

    Bei mir läuft das demnächst auch aus, insofern würde mich das auch interessieren Zumal (bei mir ist es Debian)

    sudo make-ssl-cert generate-default-snakeoil --force-overwrite

    und anschließendes Neustarten von Liveconfig und Apache an diesem Zeritfikat irgendwie nichts geändert hat, das steht da immer noch mit Ablaufdatum Anfang Dezember.

  6. #6
    Erfahrener Benutzer
    Registriert seit
    29.11.2012
    Beiträge
    257
    Genau um dieses Zertifikat geht es.
    Bei mir ist es auch Debian.
    Geändert von dicker (06.11.2018 um 11:00 Uhr)

  7. #7
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.651
    Zitat Zitat von mhagge Beitrag anzeigen
    Ich glaube das geht um das Default Server-Zertifikat für SSL für den Webserver - steht in der Liste der SSL-Zertifikate mit der Bemerkung "Default SSL-zertifikat für SNI"
    Dieses Zertifikat sollte im Normalfall ohnehin niemand zu Gesicht bekommen (wird ja nur dann ausgeliefert, wenn man per HTTPS auf eine Domain zugreifen will, die zwar in LiveConfig angelegt ist, für die aber kein eigenes Zertifikat existiert). Also über "opportunistisches HTTPS", oder falsche Verlinkung.

    Wie auch immer - der Austausch ist sogar noch wesentlich einfacher.
    1. im LiveConfig auf den Punkt "SSL-Zertifikate" gehen und dieses Zertifikat zum Bearbeiten anklicken.
    2. Bei "Zertifikat-Anforderung (CSR)" auf den Button "erzeugen" klicken, ggf. die Felder ausfüllen. Bei "Common Name" (CN) am besten so was wie "localhost" oder "Default SSL Certificate" eintragen.
    3. anschließend im Abschnitt "SSL-Zertifikat (CRT)" auf den Button "selbst unterzeichnen" klicken und den Anweisungen folgen.
    4. zum Schluß ganz unten auf den Button "speichern" klicken, um das neue Zertifikat zu übernehmen.

  8. #8
    Benutzer
    Registriert seit
    11.11.2015
    Beiträge
    41
    Naja, aber so ein abgelaufenes Zertifikat da zu haben ist auch unschön - ausserdem ist "opportunistisches HTTPS" manchmal ja auch nützlich.

    Soweit klappt das auch - nur der Schritt 4 (abspeichern) klappt nicht und da könnte ich mir vorstellen besteht sogar ein Allgemeineres Problem - das neue "Zertifikat" wird erzeigt, lässt sich aber nicht abspeichern - in der liveconfig.log steht dann

    Unknown CGI variable 'comment' -> always call initForm() before checkForm()!

  9. #9
    Erfahrener Benutzer
    Registriert seit
    02.09.2014
    Beiträge
    100
    Zitat Zitat von mhagge Beitrag anzeigen
    Naja, aber so ein abgelaufenes Zertifikat da zu haben ist auch unschön - ausserdem ist "opportunistisches HTTPS" manchmal ja auch nützlich.

    Soweit klappt das auch - nur der Schritt 4 (abspeichern) klappt nicht und da könnte ich mir vorstellen besteht sogar ein Allgemeineres Problem - das neue "Zertifikat" wird erzeigt, lässt sich aber nicht abspeichern - in der liveconfig.log steht dann
    I could confirm this also,

    couldn't use the "save" button, nothing hep-end when click it. ,

    expect this in liveconfig.log:
    [2018/11/13 08:02:32.308754] [14136|14145] Unknown CGI variable 'comment' -> always call initForm() before checkForm()!

    and then when doing ssl check on web, got this:

    https://i.imgur.com/5swPZee.png

  10. #10
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    814
    The default SSL-Certificate:

    - has a CommonName which will never match any domain name
    - is the fallback, if a domain is accessed over HTTPS and the user hasn't activated his own certificate

    The validity of this default SSL certificate shouldn't matter - at all and as stated above.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •