Startseite » Forum » LiveConfig-Foren (deutsch) » Fehler und Problembehebung » PHP-FPM Unter CentOS , falsche WebUser/Gruppe in Pool Configuration
Ergebnis 1 bis 5 von 5
  1. #1
    Erfahrener Benutzer
    Registriert seit
    18.02.2011
    Beiträge
    119

    PHP-FPM Unter CentOS , falsche WebUser/Gruppe in Pool Configuration

    Hallo,

    die von LiveConfig generieret Poolkonfiguration ist unter CentOS nicht lauffähig,
    da als "listen.owner" & "listen.group" jeweils "www-data" angegeben ist.

    Bei CentOS / Redhat müsste es 'apache' lauten.
    In der web.lua sind beide Angaben auch hardgecodet.

    fh:write("listen.owner = www-data\n")
    fh:write("listen.group = www-data\n")


    Und nebenbei, wird es zukünftig auch die Möglichkeit geben "pm.max_children = 8" als Configvariable oder idealerweise in den Angeboten zu definieren.

    VG,
    Torsten
    Torsten

  2. #2
    Erfahrener Benutzer
    Registriert seit
    18.02.2011
    Beiträge
    119
    Gibt es bereits in Info hierzu?
    Torsten

  3. #3
    Erfahrener Benutzer
    Registriert seit
    18.02.2011
    Beiträge
    119
    Gibt es bereits in Info hierzu?
    Torsten

  4. #4
    Erfahrener Benutzer
    Registriert seit
    18.02.2011
    Beiträge
    119
    *10zeichen*
    Torsten

  5. #5
    Benutzer
    Registriert seit
    05.12.2013
    Beiträge
    42
    Hier das gleiche Problem. php-fpm lässt sich nicht starten da der Benutezr www-data unter CentOS nicht bekannt ist

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •