Ergebnis 1 bis 8 von 8
  1. #1
    Benutzer
    Registriert seit
    20.09.2012
    Beiträge
    87

    Fehler mit php-XY-opt-imagick

    Guten Morgen,

    wenn ich eines der zusätzlichen PHP-Imagick-Pakete installiere, dann fehlt mir die imagick.so im jeweiligen /opt/php-x.y/lib/extension/... -Ordner und liveconfig --diag meldet verständlicherweise:

    Code:
    ...
    Running Lua diagnostics...
    PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php-7.0/lib/extensions/no-debug-non-zts-20151012/imagick.so' - /opt/php-7.0/lib/extensions/no-debug-non-zts-20151012/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php-7.0/lib/extensions/no-debug-non-zts-20151012/imagick.so' - /opt/php-7.0/lib/extensions/no-debug-non-zts-20151012/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php-7.1/lib/extensions/no-debug-non-zts-20160303/imagick.so' - /opt/php-7.1/lib/extensions/no-debug-non-zts-20160303/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php-7.1/lib/extensions/no-debug-non-zts-20160303/imagick.so' - /opt/php-7.1/lib/extensions/no-debug-non-zts-20160303/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library 'imagick.so' (tried: /opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so (/opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so: cannot open shared object file: No such file or directory), /opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so.so (/opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library 'imagick.so' (tried: /opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so (/opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so: cannot open shared object file: No such file or directory), /opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so.so (/opt/php-7.2/lib/extensions/no-debug-non-zts-20170718/imagick.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
    [INFO] Detected 'Debian GNU/Linux 9.5 (stretch)'
    ...

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.678
    Sie verwenden höchstwahrscheinlich ein PHP-Paket aus unserem "debian-test"-Repository. Die sind noch nicht stabil, der o.g. Fehler ist bekannt.
    Verschieben Sie einfach die .so-Dateien:
    Code:
    cd /opt/php-7.0/lib/php/extensions/no-debug-non-zts-20151012/
    mv *.so /opt/php-7.0/lib/extensions/no-debug-non-zts-20151012/
    Das Extension-Verzeichnis hat sich von /opt/php-X.X/lib/php/extensions nach /opt/php-X.X/lib/extensions geändert - also nicht mehr unterhalb von "php/"; ausführliche Beschreibung der neuen Pakete und aller Änderungen folgt voraussichtlich im Laufe dieses Tages, wenn alle neuen PHP-Pakete fertig sind.

  3. #3
    Erfahrener Benutzer
    Registriert seit
    21.08.2012
    Ort
    Eisenhüttenstadt
    Beiträge
    443
    Hallo

    demnach ist es bekannt das ist mit den letzten Paketen Probleme gab/gibt?

    Mit freundlichen Grüßen

    Martin Krüger
    Systemhaus EHST - Ihr IT Service in Eisenhüttenstadt
    Geschäftsinhaber: M. Krüger | Beeskower Str. 259e | D - 15890 Eisenhüttenstadt |
    Kontakt: ICQ# 117049978 | E-Mail: m.krueger@systemhaus-ehst.de

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.678
    Zitat Zitat von RB-Media-Group Beitrag anzeigen
    demnach ist es bekannt das ist mit den letzten Paketen Probleme gab/gibt?
    War die Antwort nicht eindeutig?

    Sie verwenden höchstwahrscheinlich ein PHP-Paket aus unserem "debian-test"-Repository. Die sind noch nicht stabil, der o.g. Fehler ist bekannt.
    Oder anders formuliert: in den Test-Repositories befinden sich unsere Test-Pakete - die wie also noch durchtesten bevor diese freigegeben werden. Daher kann es damit zu Problemen kommen.

    Wir generieren unsere PHP-Pakete künftig komplett anders als bisher. Das bedeutet u.A., dass wir den Build-Prozess völlig umgestellt haben. Welchen Sinn und welche Vorteile das hat, erläutere ich dann sobald alles abgeschlossen ist in einem ausführlichen Beitrag.

  5. #5
    Benutzer
    Registriert seit
    20.09.2012
    Beiträge
    87
    Super, vielen Dank für die schnelle Antwort! Das war's.

  6. #6
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.678
    Zitat Zitat von Mercator1972 Beitrag anzeigen
    Das Paket aus stable php-7.0-opt-imagick_3.4.3-1+stretch1_amd64.deb steckt die imagick.so nach /opt/php-7.0/lib/imagick.so
    Ich habe das sicherheitshalber eben mal geprüft und kann das nicht bestätigen.
    Das Paket php-7.0-opt-imagick_3.4.3-1+stretch1_amd64.deb (MD5: c9f3406347d603983006d5d4274e92b0) installiert die imagick.so an den richtigen Ort:

    /opt/php-7.0/lib/php/extensions/no-debug-non-zts-20151012/imagick.so
    (MD5: 89a1531cc2d86cd620fd3950a80657bf)

    Handelt es sich vielleicht noch um eine veraltete Datei aus einer früheren Installation/Version?

  7. #7
    Benutzer
    Registriert seit
    20.09.2012
    Beiträge
    87
    Zitat Zitat von kk Beitrag anzeigen
    Handelt es sich vielleicht noch um eine veraltete Datei aus einer früheren Installation/Version?
    Ja, ganz sicher sogar

  8. #8
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.678
    Die neuen PHP-Pakete sind ab sofort freigegeben:
    https://www.liveconfig.com/de/forum/...7-2-8)?p=16306

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •