Startseite » Forum » LiveConfig-Foren (deutsch) » Installation und Verwendung » Probleme mit PHP5 und fastcgi Error 500
Ergebnis 1 bis 5 von 5
  1. #1
    Neuer Benutzer
    Registriert seit
    26.04.2018
    Beiträge
    4

    Probleme mit PHP5 und fastcgi Error 500

    Hallo,

    ich habe ein Problem. Ich habe mir die Liveconfig Testversion geladen um den Funktionsumfang zu testen. Leider bekomme ich noch nichtmal die PHPINFO() zum laufen.

    Ich habe PHP 5.6 (Debian 9) nach Anleitung installiert und registriert und das Modul FastCGI. Im Liveconfig kann ich FastCGI nun auch auswählen.

    Nach Erstellung des Webspaces und Verknüpfung der Domain, habe ich im Hauptverzeichnis eine info.php angelegt. Diese wird aber mit dem 500er abgelehnt.

    [Thu Apr 26 10:58:14.217444 2018] [fcgid:warn] [pid 7694:tid 139820638652160] (104)Connection reset by peer: [client 280.225:51020] mod_fcgid: error reading data from FastCGI server
    [Thu Apr 26 10:58:14.217492 2018] [core:error] [pid 7694:tid 139820638652160] [client 280.225:51020] End of script output before headers: info.php

    Benutzer und Gruppe = Webbenutzer (web2)
    Rechte 755

    Woran kann sowas liegen?

    Grüße

  2. #2
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    560
    "/opt/php-5.6/bin/php-cgi -i" als User aufrufen und schauen, was passiert.

  3. #3
    Neuer Benutzer
    Registriert seit
    26.04.2018
    Beiträge
    4
    Hallo,

    da kommt die Ausgabe der PHP info...
    Da scheint etwas mit dem Webserver nicht zu stimmen vllt falsche apache fcgid version ich hab die über apt-get install libapache2-mod-fcgid
    installiert.

    Das ist echt ein Krampf das PHP5 nicht mehr unterstützt wird, meine Seiten laufen alle noch auf PHP5


    edit: es liegt am fcgid mit mod_php geht es
    Geändert von webmailfreak (26.04.2018 um 11:26 Uhr)

  4. #4
    Erfahrener Benutzer
    Registriert seit
    15.02.2016
    Beiträge
    209
    Die Seiten schleunigst auf PHP 7 umstellen. Performance ist eh besser.
    Das Gras wächst nicht schneller wenn man daran zieht

  5. #5
    Neuer Benutzer
    Registriert seit
    26.04.2018
    Beiträge
    4
    Performance ist so ne Sache bei einem einzelnen Webserver, da läuft nur der apache drauf sonst nichts weiter 16GB RAM AMZ Ryzen voll oversized für den Zweck aber genauso teuer wie mein alter i5. Ich muss das ding nur zum laufen bringen. Das Script ist halt schon alt und ich habe kein Geld das umschreiben zu lassen. Das ist keine Eigenentwicklung sondern noch b1gmail 7.2 und die Kunden nehmen die neuen b1gmail Versionen einfach nicht an.

    Aber das Script ist ja NICHT das Problem des threads sondern das fcgi generell nicht korrekt funktioniert bzw. eingerichtet wird oder whatever...die phpinfo() muss ja gehen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •