Startseite » Forum » LiveConfig-Foren (deutsch) » Installation und Verwendung » Einen Parameter in der Postfix main.cf percustom.lua ändern
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11
  1. #1
    Erfahrener Benutzer
    Registriert seit
    10.10.2014
    Ort
    Pasewalk
    Beiträge
    168

    Frage Einen Parameter in der Postfix main.cf percustom.lua ändern

    Hallo,

    aktuell habe ich - durch LC automatisch angelegt in der main.cf:

    smtpd_client_restrictions =
    permit_mynetworks,
    permit_sasl_authenticated,
    reject_invalid_hostname,
    reject_unknown_reverse_client_hostname,
    reject_rbl_client xxx,

    Nun möchte ich alternativ statt reject_unknown_reverse_client_hostname den Parameter reject_unknown_client_hostname setzen, da dieser Parameter restriktiver ist.

    Nehme ich nun in der custom.lua auf:

    postfix.LOCALCONFIG = {
    ["smtpd_client_restrictions"] = "reject_unknown_client_hostname"
    }

    Dann erhalte ich schließlich nach der aktualisierung der Konfiguration in der main.cf

    smtpd_client_restrictions =
    reject_unknown_client_hostname

    Alle anderen Parameter für smtpd_client_restrictions sind dann raus.

    Mir ist klar, dass ich natürlich alle Parameter in die custom.lua aufnehmen kann, um das gewünschte Resultat zu erreichen, mit der Folge, dass dann die entsprechenden Einstellungen im Admin-Bereich von LC (Mailserverkonfiguration, z.B. Blacklists) wirkungslos werden.

    Daher meine Frage: gibt es eine Möglichkeit reject_unknown_reverse_client_hostname durch reject_unknown_client_hostname mittels custom.lua zu ERSETZEN, ohne die anderen Parameter mit aufzunehmen oder bleibt mir dann nur, das direkt in der /usr/lib/liveconfig/lua/postfix.lua zu ändern und die Änderung nach jedem LC-Update wieder einzupflegen.
    Internette Grüße
    Reiko Kretzschmar

  2. #2
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    166
    Hi,

    füge doch einfach die fehlenden Parameter in der custom.lua hinzu?


    Gruß Ralf

  3. #3
    Erfahrener Benutzer
    Registriert seit
    10.10.2014
    Ort
    Pasewalk
    Beiträge
    168
    Danke Ralf, aber wenn ich nur den fehlenden Parameter in der custom.lua aufnehme, also:

    postfix.LOCALCONFIG = {
    ["smtpd_client_restrictions"] = "reject_unknown_client_hostname"
    }

    Dann wird in der main.cf der gesamte Bereich

    smtpd_client_restrictions =
    permit_mynetworks,
    permit_sasl_authenticated,
    reject_invalid_hostname,
    reject_unknown_reverse_client_hostname,
    reject_rbl_client xxx,

    erstetzt durch:

    smtpd_client_restrictions =
    reject_unknown_client_hostname

    was ja nicht Sinn der Sache ist. Natürlich kann ich auch die
    permit_mynetworks,
    permit_sasl_authenticated,
    reject_invalid_hostname,
    reject_unknown_reverse_client_hostname,
    reject_rbl_client xxx,
    mit in die custom.lua aufnehmen, aber das ist nicht optimal, da dann bestimmte Einstellungen, die ich in Liveconfig direkt an der Postfixkonfiguration vorgenommen habe, nicht greifen.

    Gibt es keine andere Lösung?
    Internette Grüße
    Reiko Kretzschmar

  4. #4
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    166
    Hi,

    was für Einstellungen greifen dann nicht mehr? Wir haben bei uns wie oben beschrieben gearbeitet und bisher keine Probleme...

    Gruß Ralf

  5. #5
    Erfahrener Benutzer
    Registriert seit
    10.10.2014
    Ort
    Pasewalk
    Beiträge
    168
    reject_rbl_client xxx,
    reject_rbl_client xxy,
    reject_rbl_client xxz,

    xxx, xxy und xxz kann man in der LC-Oberfläche bei der Mailserverkonfiguration eintragen, Registerkarte Viren/Spam, dort DNS-Blacklists.
    Internette Grüße
    Reiko Kretzschmar

  6. #6
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    166
    Hi,

    na ja, das sind bei uns sehr statische Einträge. Die pflegen wir in der custom.lua

  7. #7
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59
    Hallo, habe dazu auch mal eine Frage, muss man die Einträge jeweils in Hochkammas und via Komma getrennt adden, oder alles in Hochkammas und dazwischen nen Komma?
    Also Bsp:
    postfix.LOCALCONFIG = {
    ["smtpd_recipient_restrictions"] = "reject_non_fqdn_hostname","reject_non_fqdn_recipi ent","reject_sender_login_mismatch","reject_multi_ recipient_bounce","reject_non_fqdn_helo_hostname"
    }
    MfG

  8. #8
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    166
    Hi,

    Mit Hochkommas und durch Komma getrennt...

    Gruß Ralf

  9. #9
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59
    Hi, also so wie ich es jetzt habe oder nur am Anfang und am Ende Hochkomma. Sieht man in der Anleitung bei lc leider nichts dazu.

  10. #10
    Erfahrener Benutzer
    Registriert seit
    06.11.2012
    Beiträge
    166
    Hi,

    Funktionierendes Beispiel:
    ["smtpd_sender_restrictions"] = "hash:/etc/postfix/nosend, pcre:/etc/postfix/rejected_domains, permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname,reject_unknown_helo_h ostname,reject_unknown_address,reject_unknown_send er_domain,reject_non_fqdn_sender,check_sender_acce ss hash:/etc/postfix/sender_access";

    Gruß Ralf

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •