Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 39
  1. #1
    Benutzer
    Registriert seit
    17.09.2013
    Beiträge
    35

    Server Zertifikat

    Hallo Zusammen,

    ich würde gerne LE auch zur Sicherung des Servers selbst (also server1.host.de) verwenden. Wenn ich jedoch den Hostname im ACME angebe, sagt LC, dass der Domainname nicht gefunden wurde (vermutlich weil kein Vertrag + Domain dazu angelegt ist).

    Wie wäre hier das richtige vorgehen? Generell wäre es ja gerade auch für den LC Login schön mit LE zu arbeiten.

    Vg,
    Patrick Kambach

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.587
    Einfachste Lösung ist, als "admin" unter "Mein Hosting" einen Vertrag anzulegen und diesem die Domain "server1.host.de" zuzuordnen - dann kann ein SSL-Zertifikat via Let's Encrypt beantragt werden.
    LE macht einen HTTP-Zugriff zur Authentifizierung, daher braucht man derzeit zwangsweise einen Webspace. Eine Authentifizierung per DNS ist zwar schon spezifiziert, wird von LE aktuell aber noch nicht angeboten.

    Was LiveConfig betrifft: aktuell kann das Zertifikat für LiveConfig nur "von Hand" verwaltet werden (default: /etc/liveconfig/sslcert.pem) - wir planen aber das auch über die LC-Oberfläche verwaltbar zu machen und somit auch Let's Encrypt nutzen zu können (sonst müsste man das ja alle 90 Tage von Hand austauschen...)

  3. #3
    Benutzer
    Registriert seit
    17.09.2013
    Beiträge
    35
    Hallo Herr Keppler,

    vielen Dank, das hatte ich gerade versucht und es hat nicht geklappt Der Server, um den es hier geht, ist ein "Slave" - d.h. da läuft nur der "lcclient". Das Webspace-Paket ist dem Server richtig zugeordnet und die Domain kann ich auch aufrufen.

    Jedoch war die Validierung nicht möglich; laut Logdatei konnte die Config für LE nicht angelegt werden:

    Code:
    [2015/11/19 10:24:41.476906] [42838|42840] [LUA] Detected 'Debian GNU/Linux 8.2 (jessie)'
    [2015/11/19 10:24:41.612481] [42838|42840] [LUA] PHP command line interface (CLI) can't be used with addPHP() - please use CGI/FCGI/FPM SAPI (/usr/bin/php)
    [2015/11/24 11:00:20.242119] [42838|42841] [LUA] Adding system account 'web0'
    [2015/11/24 11:00:20.412847] [42838|42839] [LUA] LC.exec(/usr/sbin/a2dissite web0.conf): program output: Site web0 already disabled
    [2015/11/24 11:00:20.412957] [42838|42839] [LUA] Removing '/etc/apache2/sites-available/web0.conf' (no vHosts configured)
    [2015/11/24 11:00:30.635533] [42838|42841] [LUA] LC.exec(/etc/init.d/apache2 reload): program output: Reloading apache2 configuration (via systemctl): apache2.service.
    [2015/11/24 11:00:41.462029] [42838|42840] [LUA] LC.exec(/usr/sbin/a2ensite web0.conf): program output: Enabling site web0.
    To activate the new configuration, you need to run:
      service apache2 reload
    [2015/11/24 11:00:51.681831] [42838|42839] [LUA] LC.exec(/etc/init.d/apache2 reload): program output: Reloading apache2 configuration (via systemctl): apache2.service.
    [2015/11/24 11:00:59.484044] [42838|42841] [LUA] LC.fs.setperm: No such file or directory
    [2015/11/24 11:00:59.484094] [42838|42841] [LUA] Can't open '/var/www/web0/conf/acme/YJlzUVBbcK36lFsoj9E_VxXO7qT3tStUjgE6zvUebpM' for writing: /var/www/web0/conf/acme/YJlzUVBbcK36lFsoj9E_VxXO7qT3tStUjgE6zvUebpM: No such file or directory
    [2015/11/24 11:00:59.538994] [42838|42841] [LUA] LC.exec(/usr/sbin/a2ensite web0.conf): program output: Site web0 already enabled
    [2015/11/24 11:01:09.760549] [42838|42840] [LUA] LC.exec(/etc/init.d/apache2 reload): program output: Reloading apache2 configuration (via systemctl): apache2.service.
    Viele Grüße,
    Patrick Kambach

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.587
    Ok, auf dem Server ist vermutlich kein PHP installiert. Das führt dazu, dass LiveConfig das Verzeichnis ~/conf/ nicht anlegt, während der ACME-Code davon ausgeht dass das existiert.
    Werden wir gleich beheben.

    Workaround bis dahin: legen Sie das Verzeichnis ~conf/ manuell an (mode=0755, owner=root:root) und starten erneut eine Authentifizierung (einfach das angelegte SSL-Zertifikat noch mal erneut speichern).

    Viele Grüße

    -Klaus Keppler

  5. #5
    Benutzer
    Registriert seit
    17.09.2013
    Beiträge
    35
    Hallo Herr Keppler,

    okay, damit klappt es dann. PHP ist auf dem System installiert, war aber nicht beim Webspace aktiviert. Ein nachträgliches aktivieren hat auch nicht geholfen:

    Code:
    [2015/11/24 11:49:37.144074] [42838|42839] [LUA] LC.exec(/usr/sbin/a2ensite web0.conf): program output: Site web0 already enabled
    [2015/11/24 11:49:47.243094] [42838|42841] [LUA] LC.exec(/etc/init.d/apache2 reload): program output: Reloading apache2 configuration (via systemctl): apache2.service failed!
    [2015/11/24 11:49:47.243145] [42838|42841] [LUA] LC.exec(/etc/init.d/apache2 reload): error output: Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
    [2015/11/24 11:49:47.243166] [42838|42841] [LUA] LC.exec(/etc/init.d/apache2 reload): exited with return code 1
    Und dann:

    Code:
    systemctl status apache2.service
    ● apache2.service - LSB: Apache2 web server
       Loaded: loaded (/etc/init.d/apache2)
       Active: active (running) (Result: exit-code) since Thu 2015-10-29 14:18:44 CET; 3 weeks 4 days ago
      Process: 20720 ExecReload=/etc/init.d/apache2 reload (code=exited, status=1/FAILURE)
       CGroup: /system.slice/apache2.service
               ├─20408 /usr/lib/liveconfig/lclogsplit -m /etc/apache2/accesslog.map -s /var/lib/liveconfig/apachelog.stats
               ├─20409 /usr/sbin/apache2 -k start
               ├─20411 /usr/sbin/apache2 -k start
               ├─20412 /usr/sbin/apache2 -k start
               ├─20413 /usr/sbin/apache2 -k start
               ├─20414 /usr/sbin/apache2 -k start
               ├─20415 /usr/sbin/apache2 -k start
               ├─20425 /usr/sbin/apache2 -k start
               └─62539 /usr/sbin/apache2 -k start
    
    Nov 24 11:49:47 servername systemd[1]: Reload failed for LSB: Apache2 web server.
    Nov 24 11:50:54 servername apache2[20720]: Reloading web server: apache2 failed!
    Nov 24 11:50:54 servername apache2[20720]: The apache2 configtest failed. Not doing anything. ... (warning).
    Nov 24 11:50:54 servername apache2[20720]: Output of config test was:
    Nov 24 11:50:54 servername apache2[20720]: AH00526: Syntax error on line 64 of /etc/apache2/sites-enabled/web0.conf:
    Nov 24 11:50:54 servername apache2[20720]: Wrapper /var/www/web0/conf/php5/php-fcgi-starter cannot be accessed: (2)No such file or directory
    Nov 24 11:50:54 servername apache2[20720]: Action 'configtest' failed.
    Nov 24 11:50:54 servername apache2[20720]: The Apache error log may have more information.
    Nov 24 11:50:54 servername systemd[1]: apache2.service: control process exited, code=exited status=1
    Nov 24 11:50:54 servername systemd[1]: Reload failed for LSB: Apache2 web server.
    Vg,
    Patrick Kambach

  6. #6
    Benutzer
    Registriert seit
    20.09.2012
    Beiträge
    86
    Zitat Zitat von kk Beitrag anzeigen
    ... wir planen aber das auch über die LC-Oberfläche verwaltbar zu machen und somit auch Let's Encrypt nutzen zu können (sonst müsste man das ja alle 90 Tage von Hand austauschen...)
    Oh, das wäre top!

  7. #7
    Erfahrener Benutzer
    Registriert seit
    02.09.2014
    Beiträge
    100
    Zitat Zitat von kk Beitrag anzeigen
    Einfachste Lösung ist, als "admin" unter "Mein Hosting" einen Vertrag anzulegen und diesem die Domain "server1.host.de" zuzuordnen - dann kann ein SSL-Zertifikat via Let's Encrypt beantragt werden.
    LE macht einen HTTP-Zugriff zur Authentifizierung, daher braucht man derzeit zwangsweise einen Webspace. Eine Authentifizierung per DNS ist zwar schon spezifiziert, wird von LE aktuell aber noch nicht angeboten.
    I have a question regarding this written above,
    on my liveconfig server(business license) is installed only liveconfig, postfix, dovecot,..... ie. liveconfig and mail service complete, meaning no Web service at all,

    My question relates to the LE, whether in such server, can install and configure SSL with LE.
    SSL for accessing liveconfig web panel.

    above that I have read claim that at the opening of the subscription, subscription must runs on a web service.

    My web services unrelated with liveconfig, They are centered on lcclient1 and lcclient2.

    1.liveconfig(mail services) - business license
    2.lcclient(nginx,php,mysql,...) - standard license
    3.lcclient(apache,php,mysql,...) - standard license

    all three server are in different DataCenters.

    certificate for liveconfig panel access expires in few days and it would be very good if I don't have to renew it, and spend my money on it, ie. if I can set access to liveconfig over LE/SSL-a.

    Mr Keppler, if you have any idea, or reply to this what is written above, please reply as soon as possible

    best regards,

  8. #8
    Benutzer
    Registriert seit
    11.10.2013
    Beiträge
    98
    Zitat Zitat von kk Beitrag anzeigen
    Was LiveConfig betrifft: aktuell kann das Zertifikat für LiveConfig nur "von Hand" verwaltet werden (default: /etc/liveconfig/sslcert.pem) - wir planen aber das auch über die LC-Oberfläche verwaltbar zu machen und somit auch Let's Encrypt nutzen zu können (sonst müsste man das ja alle 90 Tage von Hand austauschen...)
    Hallo Herr Keppler,

    gibt es dazu schon was neues bzw. eine Lösung?
    Geändert von bravesurfer (28.04.2016 um 18:22 Uhr)

  9. #9
    Benutzer
    Registriert seit
    26.07.2013
    Beiträge
    54
    Das würde mich auch sehr interessieren. :-)

  10. #10
    Erfahrener Benutzer
    Registriert seit
    23.02.2013
    Beiträge
    211
    Für diejenigen die nicht warten können, löst doch eines bei WoSign (2 Jahre für nix)
    https://buy.wosign.com/free/#ssl

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •