Startseite » Forum » LiveConfig Forums (english) » Bugs and troubleshooting » AH01797: client denied by server configuration:
Ergebnis 1 bis 7 von 7
  1. #1
    Erfahrener Benutzer
    Registriert seit
    09.07.2012
    Ort
    Spanien
    Beiträge
    280

    AH01797: client denied by server configuration:

    Hab diesen fehler bei configurieren neuen SSL Zertifikat. Jemand weiss was das bedeutet?

  2. #2
    Erfahrener Benutzer
    Registriert seit
    09.07.2012
    Ort
    Spanien
    Beiträge
    280
    Seht so aus dat Apache config ist fehlerhaft. Was ist passiert mit LC.

  3. #3
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.309
    Was genau ist fehlerhaft?
    Was liefert der Befehl "apache2ctl configtest"?

  4. #4
    Erfahrener Benutzer
    Registriert seit
    09.07.2012
    Ort
    Spanien
    Beiträge
    280
    Ich rede hier über:
    liveconfig -v
    _ _ ___ __ _ (R)
    | | (_)_ _____ / __|___ _ _ / _(_)__ _
    | |__| \ V / -_) (__/ _ \ ' \| _| / _` |
    |____|_|\_/\___|\___\___/_||_|_| |_\__, |_____________________________________
    |___/
    Version: 1.8.3
    Platform: x86_64-unknown-linux-gnu
    Revision: 3577
    __________________________________________________ ____________________________
    Copyright (c) 2009-2015 Keppler IT GmbH. http://www.liveconfig.com


    Ich habe den Kundensite vorlaufig wieder repariert.

    Es fehlten

    Order allow,deny
    Allow from all

    bevor:

    Require all granted

  5. #5
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.309
    Zitat Zitat von ñull Beitrag anzeigen
    Es fehlten

    Order allow,deny
    Allow from all

    bevor:

    Require all granted
    Wo genau (also in welcher Datei und dort an welcher Stelle) soll das gefehlt haben?
    Welche Apache-Version verwenden Sie genau? (bzw. welche Linux-Distribution & -Version)

    Ab Apache 2.4 gilt die "neue" Syntax ("Require all granted" statt Order/Allow).

  6. #6
    Erfahrener Benutzer
    Registriert seit
    09.07.2012
    Ort
    Spanien
    Beiträge
    280
    Datei: /etc/apache2/sites-available/<user>.conf
    Stelle zwischen:
    <Directory "/var/www/<user>/htdocs/<domain>">
    Options SymLinksIfOwnerMatch MultiViews
    AllowOverride AuthConfig FileInfo Indexes Limit Options=Indexes,MultiViews,SymLinksIfOwnerMatch

    Und:
    Require all granted
    </Directory>


    Mit "Order allow,deny" und "Allow from all" dazwischen funktionierte es wieder.


    Es geht um Apache 2.4.7 unten Ubuntu 14.04 LTS
    Geändert von ñull (12.06.2015 um 18:20 Uhr)

  7. #7
    Erfahrener Benutzer
    Registriert seit
    09.07.2012
    Ort
    Spanien
    Beiträge
    280
    Ich entdeckte eine abweichendes Verhalten von Apache. Der einzige Weg es kompatibel mit LC zu machen ist durch Deaktivierung vom access_compat:

    a2dismod access_compat

    Dann muss natürlich "Order allow,deny" überall verschwunden sein. Das erklärt noch immer nicht warum es nicht funktionierte, vor allem weil auf meine Virtualbox Probeserver das alles kein Problem war.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •