Startseite » Forum » LiveConfig Forums (english) » Bugs and troubleshooting » v1.7.4-r3081 Spamassassin und Catachall-Adressen funktioniert nicht
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12
  1. #1
    Benutzer
    Registriert seit
    13.07.2012
    Beiträge
    59

    v1.7.4-r3081 Spamassassin und Catachall-Adressen funktioniert nicht

    Moin,

    ich weiss, über den Sinn und Unsinn von Catchall wollen wir nicht reden! Leider dringt das trotz Aufklärungsversuchen nicht zu allen Kunden durch .
    Wenn man für eine Catchall-Adresse den Spamfilter aktiviert dann wird in die Datei /etc/postfix/spamassassin ein korrekter Eintrag in der Form @dom.com 1 3 5 1 webblabla ***SPAM-Verdacht*** angelegt.

    Wenn nun eine Mail an mail@dom.com geschickt wird, werden die Mails nicht durch Spamassassin geschickt.


    Beste Grüße

    eiclinde

  2. #2
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.309
    Ja, derzeit werden Catchall-Adressen beim SpamAssassin (bzw. lcsam) nicht berücksichtigt. Die einfachste Lösung für uns wäre, wenn eine Abfrage an /etc/postfix/spamassassin nach einer konkreten Mailadresse erfolglos war (z.B. "mail@dom.com"), danach eine zweite Abfrage zu machen - in diesem Fall nach "@dom.com".
    Der Haken daran ist aber: wenn z.B. ein Postfach "info@dom.com" eingerichtet und SpamAssassin dafür deaktiviert ist, dann steht diese Adresse auch nicht in /etc/postfix/spamassassin - der erste Lookup liefert also kein Ergebnis, während der zweite Lookup (@dom.com) dann die Einstellungen des Catchall-Postfachs zurückgibt.

    Mit anderen Worten: die SpamAssassin-Einstellungen von Catchall-Postfächern würden somit gleichzeitig für alle normalen Postfächer gelten, bei denen SpamAssassin deaktiviert ist.

    Die einzige saubere Lösung wäre, Postfächer mit deaktiviertem SpamAssassin auch explizit in die /etc/postfix/spamassassin mti aufzunehmen (und dort eben irgendwie als "no SpamAssassin" zu hinterlegen). Das würde die spamassassin-Benutzerliste aber auf einen Schlag ziemlich aufblasen. :-/

    Wir tendieren nun eher dazu, bei Catchall-Adressen die SpamAssassin-Option komplett zu deaktivieren (schließlich funktioniert das aktuell ja ohnehin nicht). Wenn zudem etwa eine eingehende Spam-Attacke an zufällige Empfängeradressen läuft, würde das mit Catch-All auch eine gefährliche Serverlast mit sich bringen, wenn jede dieser Mails dann erst durch SpamAssassin durchgeschoben wird.

    Viele Grüße

    -Klaus Keppler

  3. #3
    Benutzer
    Registriert seit
    01.11.2015
    Beiträge
    30
    Gibt es hier Pläne das zu ändern bzw. gibt es mittlerweile sinnvolle Workarounds?
    Ich habe mit bestehenden Catchall Adressen zu LC migriert und finde das Verhalten äußerst ärgerlich (bitte jetzt keine Diskussion zur Sinnhaftigkeit).

    Damit dass ein aktivierter SA dann zwangsweise auch für alle "untergeordneten" Accounts einer Domain gilt hätte ich kein Problem. Mit den 30-40 Spammails die wegen deaktiviertem SA aktuell pro Tag durchkommen allerdings schon.

  4. #4
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.309
    Mit v2.1.0-r4080 wird es bei CatchAll-Accounts nicht mehr möglich sein, den Spamfilter über die Oberfläche zu aktivieren. Bei bestehenden CatchAll-Accounts, bei denen diese Option gesetzt war, wird diese automatisch entfernt.
    Gleichzeitig unterstützt der LiveConfig SpamAssassin-Milter ("lcsam") ab dieser Version aber "CatchAll"-Einträge in der /etc/postfix/spamassassin.db
    Der Workaround wäre dann also, für die gewünschten CatchAll-Accounts manuell entsprechende Einträge in /etc/postfix/spamassassin anzulegen.

    Eine kurze Anleitung dazu gibt's wenn wir die Preview aktualisiert haben (spätestens Donnerstag).

    Viele Grüße

    -Klaus Keppler

  5. #5
    Benutzer
    Registriert seit
    01.11.2015
    Beiträge
    30
    Hallo,

    vielen Dank für die schnelle Rückmeldung und die geplante Umsetzung!

  6. #6
    Benutzer
    Registriert seit
    01.11.2015
    Beiträge
    30
    Hallo,

    gibt es die angekündigte Anleitung schon? Bin noch nicht fündig geworden.

  7. #7
    Erfahrener Benutzer
    Registriert seit
    06.04.2012
    Beiträge
    443
    Hallo,

    Zitat Zitat von kk Beitrag anzeigen
    Eine kurze Anleitung dazu gibt's wenn wir die Preview aktualisiert haben (spätestens Donnerstag).
    Ich konnte die auch noch nicht finden...

    herzliche Grüße
    Matthias Knick

  8. #8
    Benutzer
    Registriert seit
    01.11.2015
    Beiträge
    30
    Hallo,

    gibt es hierzu zwischenzeitlich etwas neues?

    Grüße

  9. #9
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.309
    Hallo,

    um Spam-Filter für Catch-All-Accounts einzurichten, geben Sie bitte wie folgt vor:
    - legen Sie im LiveConfig einen CatchAll-Account an (als Weiterleitung auf irgendeine bestehende E-Mail-Adresse)
    - bearbeiten Sie die Datei /etc/postfix/spamassassin: fügen Sie dort eine Zeile hinzu, welche die gewünschte SpamAssassin-Konfiguration enthält. Das Format ist:
    <Domain> 1 <PunkteFürWarnung> <PunkteFürAblehnung> 1 <Vertragsname> <PräfixFürBetreff>

    Beispiel:
    Code:
    example.org 1 2.5 6.0 1 web123 ***Spam-Verdacht***
    Danach führen Sie den Befehl "postmap /etc/postfix/spamassassin" aus, um die Datenbank-Datei zu aktualisieren.

    Grundsätzlich raten wir dringend davon ab, überhaupt CatchAll-Accounts zu nutzen. Diese stellen einen großen Angriffspunkt für Spam und DoS-Angriffe dar.

    Viele Grüße

    -Klaus Keppler

  10. #10
    Benutzer
    Registriert seit
    01.11.2015
    Beiträge
    30
    Hallo,

    leider scheint die Konfiguration so nicht zu funktionieren (entsprechendes Supportticket ist mit Logs aktualisiert).

    Grüße

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •