Startseite » Forum » LiveConfig-Foren (deutsch) » Installation und Verwendung » Spamassassin einrichten
Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 21
  1. #11
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59

    Frage

    Hallo, eine Idee?
    Code:
    systemctl status lcsam.service
    Failed to get properties: No such interface ''
    Code:
    systemctl restart lcsam.service
    Failed to restart lcsam.service: No such method 'RestartUnit'
    See system logs and 'systemctl status lcsam.service' for details.
    Code:
    systemctl status lcsam.service
    Failed to get properties: No such interface ''
    Code:
    ps aux | grep lcsam
    nobody    1880  0.0  0.0 245808   180 ?        Sl   10:51   0:00 /usr/lib/liveconfig/lcsam -g spamd -U postfix
    root      1917  0.0  0.0   4188   696 ?        Ss   10:51   0:00 /lib/startpar/startpar -f -- lcsam
    root      3703  0.0  0.0  17552  1752 pts/3    S+   10:53   0:00 grep lcsam
    Geändert von informant (21.07.2019 um 09:54 Uhr)

  2. #12
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59

    Frage

    Keiner eine Idee?

  3. #13
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.258
    Hat nichts mit LiveConfig zu tun, sondern mit dem Server insgesamt. Führen Sie "systemctl status apache2" aus - vermutlich bringt das die selbe Fehlermeldung.
    Anhand der spärlichen Fehlermeldungen kann man unmöglich sagen, was die Ursache ist. Eventuell läuft schlicht systemd nicht (z.B. wenn Upstart eingesetzt wird).

  4. #14
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59
    Hallo, korrekt systemd nutzen wir nicht, da es damals einen Bug bei der Umstellung gab. Läuft der Dienst lcsam nur unter systemd ?

  5. #15
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    693
    Zitat Zitat von informant Beitrag anzeigen
    Hallo, korrekt systemd nutzen wir nicht, da es damals einen Bug bei der Umstellung gab.
    Debian? Ubuntu?

    Läuft der Dienst lcsam nur unter systemd ?
    Nein, das ist einfach nur ein normaler Dienst, wie SpamAssassin, LiveConfig und alle anderen auch.

    Ob da nun sysv-init, Systemd, Upstart oder rc.local genutzt wird, ist letztendlich egal, solange der Dienst läuft.

  6. #16
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59
    Hi debian Stretch läuft derzeit auf dieser Maschine. Systemd bekommen wir auch nicht drauf, da der bug scheinbar noch irgendwo drin schlummert. Denn udev kann dann den Kernel device manager nicht starten,,, Daher haben wir auf dieser Maschine noch nicht umgestellt.

  7. #17
    LiveConfig-Team Avatar von kk
    Registriert seit
    10.12.2010
    Beiträge
    3.258
    Code:
    /etc/init.d/lcsam start
    Ein schlampig oder gar nicht konfiguriertes Init-System wird aber garantiert noch viel "Freude" bereiten...

  8. #18
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59
    Hallo, der Service läuft ja^^

    ps aux | grep lcsam
    nobody 7063 0.0 0.0 245808 180 pts/1 Sl 10:43 0:00 /usr/lib/liveconfig/lcsam -g spamd -U postfix
    root 7282 0.0 0.0 17552 1988 pts/1 S+ 10:46 0:00 grep lcsam
    /etc/init.d/lcsam restart
    [ ok ] Stopping lcsam: lcsam.
    [ ok ] Starting lcsam: lcsam.
    Funzt aber dennoch nicht. Es wird weder der Teststring in der eMail erkannt noch kommen die Einträge im eMail Header X-Spam-... Wie oben beschrieben...

  9. #19
    Erfahrener Benutzer
    Registriert seit
    07.04.2011
    Beiträge
    693
    Zitat Zitat von informant Beitrag anzeigen
    Funzt aber dennoch nicht. Es wird weder der Teststring in der eMail erkannt noch kommen die Einträge im eMail Header X-Spam-... Wie oben beschrieben...
    Bitte aktuelle relevante Logeinträge von Postfix, LCSam und SpamAssassin bereitstellen.

  10. #20
    Benutzer
    Registriert seit
    27.10.2012
    Beiträge
    59
    Habe gerade spamassassin neu installiert, lcclient reinstalliert, postfix restartet. Nun wird der Teststring schon mal abgelehnt. Server answered: "554 5.7.1 Your message was rejected because it appears to be spam"
    Sieht so aus, als wenn es nun klappt. Mal schauen, ob auch mal eine mit SPAM gekennzeichnete eMail ankommt.
    X-Spam-Flag: NO
    X-Spam-Score: 0.0
    X-Spam-Status:...
    kommt nun auch...
    Danke Euch^^
    PS: musste aber folgendes in /etc/default/spamassassin eintragen:
    OPTIONS="-m 5 -H --socketpath=/var/run/spamd.sock --socketowner=root --socketgroup=spamd --socketmode=0660 -x --virtual-config-dir=/var/lib/spamassassin/%u/ -u spamd"
    Geändert von informant (24.07.2019 um 10:03 Uhr)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •